MotionBoard 5.0 から 5.5 へのリリース情報

公開日時:2015/09/30 10:00 記事番号:000009485
製品ブランド:MotionBoard

機能追加事項

≪新アイテム、新オプション≫

・データの値を表す点と点を線で結び、データ同士の繋がりを視覚的に表現するアイテム
 「ネットワーク図アイテム」を追加しました。繋がりの深いデータは何か、関係するデータで規模が大きい
 のはどこかなどを判断したい場合に適しています。[#MB-103442]
・コンテナアイテムを追加しました。コンテナアイテムを使用すると、複数のアイテムをまとめて1つのアイテ
 ムのように扱えます。[#MB-102480]
・情報アイテムを追加しました。データセットの検索情報や、チャート上のデータの統計的な情報を、アイテ
 ムとしてボードに表示できます。[#MB-103224]
・ボード上に配置しているアイテムのデータを、SVFを通してレポート形式で出力できる機能を追加しました。
 当機能を使用するには、次のいずれかのライセンスが必要です。[#MB-102843]
 * MotionBoard 帳票出力オプション
 * MotionBoard SVF Connectorオプション(別途SVF製品が必要です)
・MotionBoardと離れた拠点にあるデータサーバーとで、データを安全にやり取りするための仕組みとして、
 「ブリッジサービス」を追加しました。専用回線やVPNがなくても、インターネットを介してイントラネット
 内のデータを安全にやりとりできます。なお、ブリッジサービスを使用する場合、次の点に注意してくださ
 い。[#MB-102596]
 * 別途、ブリッジサービスのライセンスの購入が必要です。
 * ブリッジサービスを経由するデータソースの場合、そのデータはインメモリテーブルに格納できません。
・システム設定に[ファイルコネクター]画面を追加しました。MotionBoardサービスが稼働しているサーバー
 上のファイルシステムやオンラインストレージサービスのファイルシステム、FTPおよびFTPSサーバー上の
 ファイルに直接アクセスするための接続設定ができます。これにより、CSVファイルやExcelファイルを
 MotionBoardサーバーにアップロードせずにデータソースとして利用できます。また、一部の機能において、
 接続先のファイルシステムをデータの保存先としても利用できます。[#MB-103064]
 接続可能なオンラインストレージサービスは、次のとおりです。
 * Amazon S3
 * Box Business、Box Enterprise
 * DropBox for Business
 * Google Drive for Work
 * OneDrive for Business

≪動作要件≫

・使用可能なOSとして、Red Hat Enterprise Linux Server release 6.6に対応しました。[#MB-18941]
・使用可能なOSとして、Red Hat Enterprise Linux Server release 7.0、7.1に対応しました。[#MB-0002]
・使用可能な外部データソースとして、HAWQ Ver. 1.xを追加しました。[#MB-103109]
・使用可能な外部データソースとして、SAP HANAを追加しました。[#MB-103698]
・使用可能な外部データソースとして、Treasure Dataを追加しました。ただし、RFM分析は使用できません。
 [#MB-9603]
・接続可能なデータベースとして、Microsoft SQL Server 2014に対応しました。[#MB-16663]
・接続可能なデータベースとして、Oracle 9i Database R2(R9.2.0.7以降)に対応しました。[#MB-18370]
・接続可能なデータベースとして、Amazon Redshift Ver. 1.xに対応しました。[#MB-18739]
・+Mobileアプリケーションの対応OSとして、iOS 8.0を追加しました。
 また、使用可能なモバイル端末として、iPhone 6とiPhone 6 Plus上での動作に対応しました。
 [#MB-18892-1]
・+Mobileアプリケーションの対応OSとして、iOS 8.1を追加しました。
 また、使用可能なモバイル端末として、iPad Air2とiPad mini3上での動作に対応しました。
 [#MB-18892-2]

≪ボード≫

・レイアウトモードのボードで、[ページ]メニューに[ページ設定]-[全ページ]を追加しました。レイア
 ウトモードのボードでも、ヘッダー/フッターなどの設定ができます。[#MB-9677-2]
・ボードに備え付けの掲示板「ボード掲示板」を追加しました。[ボード管理]画面の
 [ボード設定]タブの[ボード掲示板]がオンの場合に、メニューバーのボード名に
 マウスカーソルを合わせると、ボード掲示板が表示されます。使用方法はコメント掲示板アイテムとほぼ同じ
 ですが、ボードにアイテムを配置することなく、他のユーザーとコメントをやりとりできます。
 モバイルでは、ボード画面のボタンバーの[高度な操作]から[ボード掲示板]をタップすると、ボード掲示
 板が表示されます。[#MB-103503]
・[ボード管理]画面の[ボード設定]タブで、ボードのスクロールバーを非表示にする設定を追加しました。
 [スクロール設定]の[非表示]をオンにすると、スクロールバーは表示されませんが、ボードアイテムエリ
 アをドラッグしてボードをスクロールできます。
 [利用しない]をオンにすると、ボードをスクロールできなくなります(旧バージョンで[スクロール設定]
 の[利用しない]をオンにした場合と同様の動作です)。[#MB-102258]
・レイアウトモードのボードで、アイテムナビゲーター(モバイルの場合は[アイテム一覧])を使用できる
 ようにしました。ナビゲーターのアイテム一覧の上部にタブ名のドロップダウンリストが表示され、タブごと
 にアイテム一覧を切り替えられます。
 ※アイテム一覧の表示/非表示は切り替えられません(常に表示されます)。また、ナビゲーションバーに
  は、ナビゲーター縮尺スライダーのみ表示されます。[#MB-102286]
・レイアウトモードのボードにて、タブ上で右クリックしたときのメニューに[コピーして新規作成]を追加
 しました。Ctrlキーを押しながらタブを左右にドラッグ&ドロップしたときと同様に、タブのコピーが可能で
 す。[#MB-20942]
・レイアウトモードで、ボードまたはタブ右側の空き領域の右クリックメニューに、
 [レイアウトページタブ表示]と[レイアウトページタブ非表示]を追加しました。
 タブの表示/非表示を切り替えられます。[#MB-102058]
・レイアウトモードのボードに、アイテムの余白を設定できる機能を追加しました。上下左右の余白を、ピク
 セル単位またはレイアウトの区画に対する割合で指定できます。[#MB-102697]
・[ボード管理]画面の[ボード設定]タブに、[レイアウトモード]を追加しま
 した。ボードを区画に分割して区画ごとにアイテムを配置する[レイアウトモード]と、区画を作らず自由に
 アイテムを配置する[フリーレイアウトモード]を、ボード作成後に切り替えられます。
 レイアウトモードからフリーレイアウトモードに変更し、再びレイアウトモードに変更すると、アイテムは
 元の区画に再配置されます。[#MB-103264]
・レイアウトモードの[タブのプロパティ]画面に、[編集時のみ表示]を追加しました。
 オンにすると、指定したタブがボード編集時のみ表示され、PDF出力の対象外にできます。[#MB-103945]
・[ボード管理]画面の[ボード設定]タブから表示できる[カスタム色設定]画面で、ボードの各パーツ
 (ボードアイテムエリア全般、メニューバー、ボードツリー、アイテムナビゲーター、ナビゲーター共通)
 ごとに色を設定できるようにしました。[#MB-102703]
・[ボード管理]画面の[アイテム管理]タブに、[ロード順設定]を追加しました。ボードに配置された
 アイテムやコンポーネントの読み込み順を設定できます。[#MB-103149]
・[ボード管理]画面の[アイテム管理]タブに、[タブフォーカス順設定]を追加しました。ボードにユー
 ザーの入力を受け付けるアイテムやコンポーネントが配置されている場合、
 Tabキーを押してアイテムのフォーカスを遷移する際の順序を設定できます。[#MB-103170]
・[ボード管理]画面の[ボード設定]タブにある[一定時間でボード切り替え]に、[クリア]ボタンを追加
 しました。クリックすると、参照先のボードパスと秒数の設定を消去できます。[#MB-103773]
・[ボード管理]画面の[ボード設定]タブにある[ボードアクセスURL]に、[コピー]ボタンを追加しまし
 た。ボードアクセスURLを、クリップボードにコピーできます。
 [#MB-103774]
・[ボード管理]画面に[カスタムメニュー]タブを追加しました。メニューバー(モバイルの場合はボタン
 バー)から、ボタンアイテムを実行するメニューを作成できます。[#MB-104019]
・[ボード管理]画面の[ボード設定]タブに、[ローディング画面]を追加しました。[表示する]をオン
 にすると、ボードの読み込み時に読み込み状況を表示できます。
 [#MB-104188]
・アイテムのショートカットボタンに[ナビゲーター]を追加しました。ボタンアクションの実行順序の確認
 やボタンアイテムの編集ができる、ボタンアクションナビゲーターを表示できます。[#MB-104014-1]
・ボードツリーのボードの右クリックメニューに、[リンクボード新規作成]を追加しました。
 [#MB-104979]
・アイテムナビゲーターの右クリックメニューに、[ナビゲーター非表示]を追加しました。アイテム名または
 データセット名以外の場所の右クリックメニューから、ナビゲーターを非表示にできます。
 [#MB-104014-2]
・次の画面に、[掲示板イメージ]タブと[掲示板添付ファイル]タブを追加しました。
 コメント掲示板アイテムで使用する、画像ファイルや添付ファイルを管理できます。[#MB-104015]
 * [共有アイテム管理]画面の[掲示板]タブ
 * [ボード管理]画面の[リソース管理]タブ
・[管理]メニューに[アイテムクリップボード]を追加しました。ボード上のアイテムやデータソース定義
 をコピーし、別のボードに貼り付けられます。[#MB-102741]
・ボード上に表示されるグリッドについて、自動的にグリッドが表示される設定を追加しました。
 [表示]メニューから[グリッド]-[自動的に表示]を選択すると、アイテムの新規作成中、アイテムの
 サイズ変更中、アイテムの移動中など、アイテムの配置を変更するときだけグリッドが表示されます。
 ※旧バージョンで[グリッドを非表示]で保存したボードは、[自動的に表示]の状態で
  読み込まれます。[#MB-102742]
・各所に「いいね!」機能を追加しました。メニューバーのボード名にマウスカーソルを合わせると
 [いいね!]ボタンが表示され、クリックするとボードに[いいね!]を付けることができます。また、
 メニューバーの[スタートナビ]や、ボードツリーの内容切り替えエリアから[いいね!ランキング]を表
 示し、投票数の多いボードを確認できます。[#MB-102986]
・ボードツリー、スタートナビ、モバイルスタートナビで表示を切り替える項目に、[最近更新された]を追
 加しました。最近作成または更新されたボードの一覧を、上位30件まで表
 示できます。[#MB-102989]
・[PV]メニューに[ユーザー最新アクセス]を追加しました。ユーザーごとのアクセス日時とアクセス数を
 表示するか、アクセスごとのユーザー名とアクセス日時を表示するかを切り替えできます。[#MB-103002]
・アイテムツールバーとエディタメニューを統合する機能を追加しました。アイテムツールバーの上部のボタ
 ンをクリックするか、アイテムツールバーの右クリックメニューから[エディタメニューに統合]
 を選択すると、アイテムツールバーがエディタメニューに統合されます。[#MB-101988]
・アイテム共通のプロパティで、[位置]と[サイズ]のそれぞれに[%]を追加しました。アイテムの表示
 位置やサイズを固定値ではなく「%」で指定できるため、常に同じ位置にアイテムを表示したり、ボードア
 イテムエリアの幅やサイズのリサイズに追従してアイテムのサイズを変えたりできます。[#MB-102871]
・インメモリテーブルやスナップショット保存先を作成する際に表示される[データソース選択]画面に、
 [大容量データ]を追加しました。100万件を超える、ExcelファイルやCSVファイルを読み込めるようになり
 ます。なお、読み込み対象のExcelファイルやCSVファイルのサイズに上限があったり、一部の機能が利用
 できなくなったりするなど、制限があります。[#MB-102928]
・ボードツリー、スタートナビ、モバイルスタートナビで、ボードにNEWやUPなどのアイコンが表示されるよう
 にしました。最近作成、または更新されたボードを確認できます。[#MB-103270]
・ボードツリーでボードにマウスカーソルを合わせると表示されるツールチップに、ボードのサムネイルが表
 示されるようにしました。ボードを開く前に、ボードの内容を確認できます。[#MB-103441]
・ボード閲覧時に、操作状態を複数保存できるようにしました。[操作]メニューから[操作状態保存]を選
 択すると、名前を付けて保存できます。
 これに伴い、[操作]メニューに、[操作状態選択]と[操作状態管理]を追加しました。保存した複数の
 操作状態からボードに反映するものを選択したり、操作状態の名前の変更や削除ができます。
 [#MB-103750]
・カレンダーで日時を指定する場合に、年送りができるボタンを追加しました。年の左側にある三角のボタン
 をクリックすると、昨年または来年の同月に表示を切り替えられます。[#MB-103316]
・[タスク詳細設定]画面の[基本設定]タブに、[ページサイズ設定]を追加しました。レイアウトモード
 で作成されたボードをファイル化するときの、「1ページで収まる画面サイズ」を設定できます。レイアウト
 モードのときのみ表示されます。[#MB-101801]
・[ボード管理]画面の[タスク設定]タブに、[タスクを有効にする]を追加しました。ボードの編集、
 コピー、アップロードの作業中など、ボードに設定されているすべてのタスクを一時的に無効にしたい場合
 にオフにすることで、設定済みのタスクが意図せず実行されるのを防止できます。[#MB-103258]

≪インメモリOLAP≫

・[インメモリOLAP詳細]画面に[コントローラーサービス開始時にリロードを行う]を追加しました。
 チェックをオンにすると、インメモリOLAP のコントローラーのサービスを再起動した場合に、クラスターが
 自動リロードされ、データが再読み込みされます。[#MB-18255/01255]
・インメモリテーブルにデータを格納するときの、ワーク用メモリの使用量や処理時間を低減しました。
 低減率は、格納するデータの特性によって変わります。[#MB-18755]
・インメモリOLAPのタスクについて、異なるインメモリテーブルに対するタスクの場合は複数同時に実行できる
 ようにしました。[#MB-19179]
 * 異なるインメモリテーブルに対するタスクの場合、10個目までのタスクはステータスが「開始」となりま
  す。そのうち4個のタスクが同時に実行されます(他のカテゴリのタスクを実行している場合、その分、
  同時実行数は減ります)。残り6個のタスクは待機状態となり、実行中のタスクが完了し次第、次のタスク
  が実行されます。
 * 11個目以降のタスクは、ステータスが「処理待ち」となり、開始中のタスクが終了するまで待機します。
  タスクの有効期間内を過ぎると「期限切れ」に変わります。
・インメモリOLAPの集計で、行項目や列項目の数が多い場合に使用するワークメモリ量を低減しました。低減
 するメモリ量は、使用するデータの特性により変わります。[#MB-19211-3]
・インメモリOLAPの冗長化(冗長構成)に対応しました。複数のコントローラーやデータサーバーを組み合わ
 せることができます。これにより、可用性や、集計時のスループットの向上、また、他のデータサーバーへ
 の負荷分散が期待できます。[#MB-102544]
・インメモリOLAPのタスクの実行をキャンセルできるようにしました。[システム設定]画面の[タスク]画
 面でタスクの右クリックメニューを開くと、[キャンセルリクエスト]が選択できるようになります。なお、
 削除のタスクを実行している場合や、タスクの処理がコミット(データの確定)に達している場合はキャン
 セルできません。[#MB-102979]
・[インメモリテーブル管理]画面のテーブル一覧に、[メモリ使用量]欄を追加しました。各インメモリ
 テーブルが現時点で使用しているメモリのサイズを確認できます。[#MB-103345]
・[インメモリテーブル管理]画面にて、テーブル一覧の右クリックメニューから、インメモリテーブルの
 ダウンロードとアップロード、クラスター設定のエクスポートとインポートをできるようにしました。
 [#MB-103776]
・データソースエディタにて、データソースとしてインメモリテーブルを指定している場合の[詳細設定]画
 面に、[パフォーマンス]タブを追加しました。[パフォーマンス]タブ内には、パフォーマンスチューニ
 ング用のパラメーター[行列項目数]があり、この設定値と、行項目数や列項目数等の組み合わせ次第では、
 集計速度が向上する可能性があります。[#MB-103975]

≪チャートアイテム≫

・「Zチャート」を追加しました。業績が上がっているのか、下がっているのかを把握できます。
 [#MB-103266]
・「メッコチャート」を追加しました。全体の構成比や内訳の占める割合を表現できます。なお、通常の縦棒
 チャートとは異なり、棒の太さも構成比に加味されます。[#MB-103591]
・チャートエディタの[チャートエリア]タブにある[共通設定]-[軸]-[数値軸の設定]-
 [最大値、最小値、単位]や、チャートメニューの[軸の設定]で、[軸の表示名]のオプションとして
 [表示する]を追加しました。対象の数値軸を表示するかどうかを指定できます。[#MB-7699]
・チャートエディタの[チャートエリア]タブの[集計表設定]で、[空の行・列を表示しない]に
 [0を空として扱う]を追加しました。オンの場合、ゼロも空とみなし、すべての集計値が空またはゼロであ
 る行や列を非表示にできます。[#MB-8590]
・チャートエディタの[折れ線共通]-[折れ線の設定]-[線の太さ]の設定値に「0」を指定できるように
 しました。設定値を「0」にすると、折れ線チャートのデータポイント間の線が非表示になります。ただし、
 折れ線縦棒コンボチャート、または積み上げコンボチャートには適用されません。[#MB-18176/01232]
・チャートエディタの[チャートメニュー]タブにて、[EXCELに保存]に
 [フォーマットに合わせて値を丸める]を追加しました。集計表チャートを Excel ファイルとしてダウンロ
 ードする場合に、セルの数値を丸めた状態にするかどうかを指定できます。[#MB-18263/01274]
・チャートエディタの[チャートエリア]タブにある[共通設定]-[背景]に、[枠線の色]と
 [枠線の不透明度設定]を追加しました。[#MB-101817-1]
・チャートエディタの[チャートエリア]タブにある[共通設定]-[軸]-[数値軸の設定]-
 [ゼロの線の色]に、[ゼロの線を表示する]を追加しました。折れ線や棒系のチャートにおいて、0を示す
 線の表示/非表示を指定できます。[#MB-101817-2]
・チャートエディタの[チャートエリア]タブにある[シングル表示設定]-[シングルデジタル]に、
 [前付け文字、後ろ付け文字の使用]、[文字寄せ(横方向)]、[文字寄せ(縦方向)]の3つを追加しまし
 た。シングルデジタルチャートで、[集計項目のフォーマット]画面の[前付け文字]や[後付け文字]を
 付加した値を表示できます。また、値の表示位置も指定できます。なお、[表示形式]が[フォント指定]
 の場合に使用できます。[#MB-101820]
・チャートエディタの[チャートエリア]タブにある[円・レーダー・ゲージ設定]-[レーダー]に、
 [数値軸を逆転させる]を追加しました。オンにすると、レーダーチャートの中心に最大値、最外周に最小
 値を表示できます。[#MB-102593]
・チャートエディタの[タイトル]タブに、[フォント種別]、[横寄せ]、[縦寄せ]、[タイトルの高さ]
 を追加しました。チャートタイトルのフォントや表示位置、高さを指定できます。[#MB-102699]
・対極棒の比較対象として、列項目を指定できるようにしました。これに伴い、チャートエディタの
 [チャートエリア]タブにある[折れ線・棒系設定]-[対極棒]に、[対極棒の比較モード]を追加しま
 した。比較対象を集計項目と列項目のどちらにするかを選択できます。[#MB-102713]
・チャートエディタの[チャートエリア]タブにある[共通設定]-[軸]-[数値軸の設定]-
 [最大値、最小値、単位]や、チャートメニューの[軸の設定]で、[軸の表示名]のオプションとして
 [表示位置]を追加しました。数値軸の表示位置を指定できます。なお、パレート図の「累計比率」にも、
 [表示位置]の設定内容が反映されるようにしました。[#MB-102745]
・チャートエディタの[チャートエリア]タブにある[円・レーダー・ゲージ設定]-[円]に、[ソート順]
 を追加しました。円チャートでの値の並び順を選択できます。初期値は[降順]です。[#MB-102746]
・チャートエディタの[チャートエリア]タブにある[折れ線・棒系設定]-[折れ線共通]に、
 [折れ線を数値軸から離す]を追加しました。折れ線チャートのデータポイントが、数値軸と密着して表示
 されるようにするか、少し離れて表示されるようにするかを選択できます。[#MB-102814]
・チャートエディタの[チャートエリア]-[折れ線・棒系設定]の各項目内にある
 [データラベルの初期表示]や、ダイナミックチェンジアイコンの[ラベル表示切り替え]に、チャートエ
 リアの最後(末端)に表示されるデータポイントにのみ、データラベルを表示する選択肢を追加しました。
 なお、一部のチャートでのみ使用できます。[#MB-102815]
・チャートエディタの[チャートエリア]-[共通設定]-[全般]ー[データラベル・データチップの設定]
 に[集計項目の小数点桁数設定を軸に適用する]を追加しました。チャートアイテムの軸の数値に、
 [集計項目フォーマット設定]画面の[小数点以下桁数]の設定を適用するかどうかの設定ができます。設
 定を適用する場合、一部のチャートにおいては、データラベルにも反映されます。[#MB-102835]
・チャートエディタの[チャートエリア]タブにある[共通設定]-[軸]-[行軸の設定]に、
 [行軸の高さを指定する]、[行軸の高さ]、[行軸を折り返して表示する]を追加しました。行軸の高さ
 や幅、文字数が多い場合の挙動を指定できます。[#MB-102838]
・チャートエディタの[チャートエリア]タブにある[円・レーダー・ゲージ設定]-[円]に、
 [集計項目ごとに円を描画する]を追加しました。集計項目ごとに同心円を表示するか、1つの円としてまと
 めて表示するかを指定できます。[#MB-102950]
・チャートエディタの[チャートエリア]タブにある[共通設定]-[全般]-[アラート設定]に
 [点滅速度]を追加しました。3段階で、アラートの点滅速度を設定できます。[#MB-103156]
・チャートエディタの[分割]タブに、[分割チャートのタイトルを表示する]を追加しました。分割チャート
 それぞれにタイトルを表示するかどうかを指定できます。なお、タイトルを非表示にした場合、分割チャート
 を最大化できなくなります。[#MB-103160]
・チャートエディタの[チャートエリア]タブで、[集計表設定]や[ヒートマップ設定]にある
 「データチップのフォーマット」の設定に[スコアルール]を追加しました。データチップに、RFM項目ごと
 のスコアルールを表示できます。[#MB-103187]
・チャートエディタの各所に、[すべてオン]ボタンと[すべてオフ]ボタンを追加しました。たとえば、
 [チャートエリア]タブ内にある[データポイントアイコンの設定]や、[チャートメニュー]タブの
 [チャート切り替えメニュー]など、多数の選択肢を持つ設定項目で、選択肢のオン/オフを一括で切り替え
 ることができます。[#MB-103242]
・チャートエディタの[チャートエリア]タブにある[ヒートマップ設定]-[カラー設定]-
 [「最大値・最小値」の範囲条件]に、選択肢[軸の設定に従う]を追加しました。行列軸ヒートマップの
 最大値と最小値を、[軸の設定]に合わせることができます。[#MB-103329]
・チャートエディタの[チャートエリア]タブにある[集計表設定]-[ランキングの推移矢印]に、次の2つ
 の設定項目を追加しました。[#MB-103331]
 * 先頭は表示しない]
  オンにすると、ランキング算出の基点となる行列の最初の値には、推移矢印が表示されません。
 * 逆向きに表示する]
  オンにすると、左列または上行よりも値が高い場合に下向きの矢印が表示されます。ワーストや失敗数など
  のランキングのように、低い値を上位のランキングにしたいときに使用します。
・チャートエディタの[チャートエリア]タブにある[集計表設定]で、[行合計表示]と[列合計表示]の
 それぞれに[詳細]ボタンを追加しました。特定の、行項目または列項目の合計を非表示にできます。
 [#MB-103336]
・チャートエディタの[凡例]タブに[凡例の並び順]を追加しました。チャートの凡例の順序を逆に表示でき
 ます。[#MB-103340]
・チャートエディタの[チャートエリア]タブにある[折れ線・棒系設定]-[全般]に、
 [横チャート時の行軸表示位置を右側にする]を追加しました。横棒、100%積み上げ横棒、対極棒において、
 行軸ラベルを右側に表示できます。[#MB-103342]
・チャートエディタの[チャートエリア]タブにある[散布図・バブル設定]-[全般]に、[相関係数表示]
 を追加しました。X軸とY軸に集計項目を設定している場合に、現在の分布状態を基にした相関係数を表示で
 きます。[#MB-103630]
・チャートエディタの[チャートエリア]タブにある[折れ線・棒系設定]-[全般]に、
 [基準線を設定する]を追加しました。折れ線や棒系のチャートに対して、軸線とは別に、任意の集計項目
 値を基準にした線を引くことができます。[#MB-103666]
・チャートメニューの[予測・分析]に[データシミュレーション]を追加しました。棒系のチャートの場合
 に、チャート上のデータポイントをドラッグ&ドロップで移動したり入れ替えたりできます。これにより、
 たとえば、来月の売上が今月と同じだった場合の予算達成度の予測、分析に役立てることができます。
 [#MB-103667]
・チャートエディタの[チャートエリア]タブにある[共通設定]-[軸]-[行軸の設定]に、
 [行軸をクリック時に回転する]を追加しました。行軸をクリックしたときに、ラベルの表示内容の変更
 (表示角度の変更や、表示/非表示の切り替え)をさせるかどうかを設定できます。[#MB-103761]
・チャートエディタの[チャートメニュー]タブに、[元に戻す]を追加しました。チャートメニューに
 [元に戻す]メニューを表示するかどうかを設定できます。[#MB-103781]
・チャートエディタの[チャートエリア]タブにある[散布図・バブル設定]-[バブル]に
 [バブルのサイズに軸設定を反映させる]を追加しました。バブルのサイズを、Z軸の値ではなく、数値軸の
 設定に応じた値とするかどうかを指定できます。[#MB-103888]
・イメージチャートのフォントを指定するパラメーター「fontfamily」を追加しました。チャートアイテムの
 プロパティにある[イメージチャート](Ver. 5.5では[イメージ化])-[公開用URL]で取得したURLの
 末尾にパラメーターを付加することで、フォントを指定できます。[#MB-103896]
・チャートエディタの[チャートエリア]タブにある[共通設定]-[スタイル設定]に、
 [マウスオーバー時の色の不透明度]を追加しました。マウスカーソルが、要素に重なったときの色の不透
 明度を指定できます。なお、「0.00」を指定すると、ハイライトを消すことができます。[#MB-105037]
・ボード編集モードにおいて、チャートアイテムの数値軸上で右クリックしたときのメニューに、
 [1つに集約]または[集計項目分をすべて表示]を追加しました。チャートエディタを起動することなく、
 複数本の軸の集約や、集約の解除をより簡単に行うことができます。[#MB-105050]
・[チャートテンプレート]画面のグループ上の右クリックメニューに[インポート]と[エクスポート]を
 追加しました。チャートアイテムのテンプレートを、グループ単位でインポート/エクスポートできます。
 [#MB-19466]
・[レイヤーチャート編集]画面に、[数値軸の集約]を追加しました。チャートを重ね合わせたときの数値軸
 の集約方法を、[集約しない]、[左の軸を集約]、[右の軸を集約]、[左右の軸を集約]、
 [すべての軸を集約]から選択できます。[#MB-20487]
・対極棒、またはウォーターフォールチャートにおいて、ボード保存時に、ダイナミックチェンジアイコンの
 [左集計項目切り替え]と[右集計項目切り替え]で指定した内容も保存できるようにしました。
 [#MB-101527]
・チャートアイテムのプロパティで、[チャート]タブの[タブ]に[最大化時のみ表示]を追加しました。
 オンにすると、チャートアイテムを最大化したときのみ項目タブを使用できます。[#MB-102694]
・[集計表のスタイル]画面の[基本スタイル]タブに、[スタイル適用優先順序]と[スタイル適用方法]
 を追加しました。セルや各種ヘッダーに、カスタム行スタイルとカスタム列スタイルのどちらを優先的に適
 用するかを選択したり、未設定の項目がある場合に、どのスタイルの設定を適用するかを指定したりできま
 す。[#MB-103146]
・チャートアイテムのデザイン用テンプレートとして、「Default」という名前のテンプレートを追加しまし
 た。「Deaflut」はチャートの種類ごとに用意され、選択するとチャートのデザインをデフォルトの状態に戻
 せます。
 チャートアイテムのデザイン用テンプレートは、チャートアイテムのショートカットボタンの
 [デザイン設定]ボタンをクリックすると表示される、デザイン設定用のパネルから選択できます。
 [#MB-103231]
・[集計表のスタイル]画面にある[基本スタイル]タブに、[デフォルト]-[フォント]と[デフォルト]
 -[文字サイズ]を追加しました。集計表全体で統一したフォントや文字サイズを設定できます。なお、他
 のタブでフォントや文字サイズを指定すると、その設定内容が優先して反映されます。[#MB-103577]
・[ボードジャンプ設定]画面(Ver. 5.5では[データポイントアクション設定]画面)に、[表示名を設定]
 を追加しました。チャートアイテムの右クリックメニューにて、データポイントアクション設定のメニュー
 項目を任意の名称で表示するかどうかを設定できます。[#MB-103320]
・チャートエディタの[全般]タブにある[色の設定]-[背景色スタイル]に、[標準]ボタンを追加しま
 した。[標準]ボタンをクリックすると、チャートアイテムの色を標準の色(グレー)に戻せます。
 また、同タブに[チャートの背景色]を追加しました。チャートメニュー、項目、チャートエリアを除く、
 チャートアイテムの背景色を自由に指定できます。[#MB-103063]
・チャートエディタの[凡例]タブに[フォントサイズ]を追加しました。 10~50の範囲で指定し、凡例の
 フォントサイズを変更できます。[#MB-103241]
・チャートエディタの[チャートエリア]タブにある[円・レーダー・ゲージ設定]-[円]に、
 [中心に合計表示]を追加しました。円グラフの中心に、現在表示中の集計項目の項目名と合計値を表示で
 きます。[#MB-103268]
・チャートエディタの[チャートエリア]タブにある[共通設定]-[軸]-[数値軸の設定]-
 [最大値、最小値、単位]や、チャートメニューの[軸の設定]に、[軸の最大値の設定]を追加しました。
 倍率または加算する値を指定して、表示する軸の最大値を変更できます。なお、[軸の固定]で
 [自動で最小/最大値を設定する]を選択した場合に適用されます。[#MB-103312]
・チャートエディタの[チャートエリア]タブにある[集計表設定]-[集計表]-[集計表の設定]に、
 [リレーション、ドリル、データポイントアクションの適用範囲]を追加しました。リレーション、ドリル
 アクション、データポイントアクションの使用可能な場所を限定できるようにしました。[#MB-103322]
・[列スタイルを変更する]画面に[カラー設定]ボタンを追加しました。[カラー設定]ボタンをクリック
 すると[カラー設定]画面が表示され、行項目、列項目、集計項目ごとに色を変更できます。なお、
 [カラー設定]ボタンは、ボード編集モードのときのみ表示されます。[#MB-103958]

≪明細表アイテム≫

・カード形式の明細表アイテムにおいて、レコードの追加やデータの更新、削除をできるようにしました。
 [#MB-8627]
・[カード明細表設定]画面のレイアウトエリアにおいて、複数のアイテムを選択したときに表示されるツー
 ルボックスや右クリックメニューに、次の項目を追加しました。複数のアイテムの配置位置を一括で揃える
 ことができます。[#MB-101066]
 * 左揃え
 * 右揃え
 * 上揃え
 * 下揃え
・明細表のアイテムプロパティの[明細表]タブに、[左クリックに割り当てる機能]を追加しました。
 ワンクリックでボードジャンプ(Ver. 5.5ではデータポイントアクション設定)やリンクを実行できるように
 なります。[#MB-101823]
・[カード明細表設定]画面の[エリア設定]タブに、[枠線表示]を追加しました。カード明細表の表示エ
 リアの枠線を表示するかどうかを指定できます。[#MB-103143]
・明細表アイテムのプロパティの[明細表]タブに、[タイトル文字の横位置(詳細形式)]を追加しました。
 詳細形式の明細表において、見出し文字の横位置を指定できます。[#MB-103144]
・明細表アイテムのプロパティの[明細表]タブに、[行番号]を追加しました。一覧形式の明細表において、
 明細表左端に表示される行番号の表示/非表示を指定できます。[#MB-103193]
・明細表アイテムのプロパティに、[選択色]、[サイズ変更色]、[新規色]、[更新色]、[削除色]の
 5つの項目を追加しました。セルや行などを選択したりサイズを変更したりしたときや、レコードの追加や
 削除、データを更新したときの色を、それぞれ指定できます。[#MB-103307]
・明細表アイテムのプロパティに[ページコントロール]を追加しました。明細表メニューのページ切り替え
 アイコンに対して、表示/非表示を設定できます。「明細表のデータが1件の場合のみページ切り替えアイコ
 ンを表示しない」という設定も可能です。[#MB-103310]
・明細表アイテムでも、アイテムプロパティから[ボードジャンプ設定](Ver. 5.5では
 [データポイントアクション設定])を使用できるようにしました。この設定をすると、明細表の行を右ク
 リックしたときに表示されるメニューから次の内容を実行できます。[#MB-103311]
 * 右クリックした行の値をシステム変数に格納する。
 * 指定したボードに遷移する(開く)。
 * 指定したボタンアイテムを実行する。
・[カード明細表設定]画面のアイテム選択エリアに、[その他]タブを追加しました。[その他]タブから、
 テキストや、ボード専用または共有フォルダーにある画像を配置できます。[#MB-103530]
・明細表アイテムにおいて、レコードを追加できるようにしました。[#MB-103886]

≪GEOアイテム≫

・GEOアイテムにGEOコーディング機能を追加しました。住所情報やIPアドレスを緯度経度に変換して、地図上に
 ポイントやメッシュで描画できます。また、住所から緯度経度への変換ルール(対応表)を登録するカスタム
 住所登録機能や、住所を検索する機能などの補助機能も用意しています。なお、当機能を使用するには別途
 ライセンスが必要です。[#MB-103425]
・[システム設定]に、GEOアイテム(GEOコーディング)で用いる住所、緯度、経度を登録する
 [カスタム住所登録]画面を追加しました。カスタム住所を登録することによって、GEOアイテム
 (GEOコーディング)で不一致データとなり表示できなかった住所を表示できるようになります。
 [#MB-103566]
・GEOアイテムの[レイヤー情報ファイル選択]-[Sample]フォルダー内にポイントレイヤーのサンプル
 「日本_駅_ポイントレイヤー.mbgis」を追加しました。日本の鉄道の、駅の情報を利用できます。
 [#MB-18240]
・GEOアイテムにおいて、データソースを使用しないGEOアイテムを作成できるようにしました。集計結果など
 を表示せずに、単なる地図としてGEOアイテムを利用できます。[#MB-101696]
・GEOアイテムにおいて、メッシュコードのデータソースに対応しました。メッシュコードに対応するメッシュ
 (編み目のエリア)を地図上に描画できます。[#MB-102889]
・画像ファイルの撮影地点の緯度経度情報を基に、画像のサムネイルをGEOアイテム上に表示する機能を追加し
 ました。GEOアイテムのプロパティ画面の[詳細設定]タブにある、[Exif画像監視]タブで設定できます。
 [#MB-102923]
・GEOアイテムにおいて、データとレイヤーの情報が一致しない場合に、[不一致データ一覧]画面から不一致
 データのCSVファイルをダウンロードできるようにしました。[#MB-102933-1]
・GEOアイテムでレイヤーを追加する際、レイヤーのプレビューを表示できるようにしました。
 [レイヤー情報ファイル選択]画面の[プレビュー]ボタンから表示できます。[#MB-103245]
・GEOアイテムを画像に変換(イメージ化)し、表示時間を短縮できる「イメージGEO」を追加しました。イメー
 ジチャートと同様、基となるGEOアイテムが存在するボードに配置したり、公開用URLを生成してWebブラウザ
 ーから参照したりできます。なお、一部、イメージGEOに反映されない項目や設定、パーツがあります。
 [#MB-103300-1]
・GEOアイテムのポイントのシンプル、値、ピンに、次の色の設定方法を追加しました。GEOアイテムのプロパ
 ティ画面の[ポイント設定]タブで、該当のタブにある色設定で変更できます。[#MB-103375]
 * 値の範囲に対する色を個別で指定するための[個別指定]を追加しました。色セットで色、値の最大値、
  最小値を設定できます。
 * 2つの値項目から色を塗るための[2つの値から指定]を追加しました。一方が大きくて、もう一方が少な
  い場合の色など、2つの値項目を基にした色の設定ができます。
・GEOアイテムにデータの推移を地図上で確認できる機能を追加しました。スライダーで表示されるデータを
 切り替えることにより確認できます。[利用データタイプ]と[マッピングタイプ]の組み合わせが、
 [チャートデータ]と[エリア名]で作成されたGEOアイテムの場合に利用できます。GEOアイテムのプロパ
 ティ画面の[詳細設定]タブで、[その他]タブにある[集計設定]で設定します。[#MB-103548]
・GEOアイテムにおいて、GPSで取得した現在地情報を地図上に描画する機能を追加しました。移動した経路を
 地図上に表示できます。GPS機能付きのモバイル端末上で利用できます。[#MB-103590]
・GEOアイテム上でクリックした地点間の距離を測定できる機能を追加しました。GEOアイテム上の距離測定ア
 イコンから、距離測定モードに移行して測定します。GEOアイテムのプロパティ画面の[詳細設定]タブにあ
 る、[距離測定アイコン]でアイコンの表示/非表示を設定できます。[#MB-103833]
・GEOアイテムへのリレーションのアクションにハイライトを追加しました。リレーション時、地図上の該当箇
 所をハイライトできます。[リレーション設定]画面の[マウスクリック時アクション]で設定します。
 [#MB-104003]
・GEOアイテム上に同心円を表示する機能を追加しました。同心円のリレーション機能を有効にすることで、
 表示圏内のポイント情報をリレーションで利用することもできます。GEOアイテムのプロパティ画面の
 [詳細設定]タブで、[その他]タブにある[同心円表示]で設定します。[#MB-104232]
・GEOアイテム上にサムネイル表示する写真などのExif画像ファイル(Exif情報付き画像ファイル)を管理でき
 るようにしました。[管理]メニューから[システム設定]-[データ]-[Exif画像監視]を選択し、表
 示される[Exif画像監視]画面で管理します。[#MB-104302]
・GEOアイテムの周辺情報取得機能で取得したポイント情報を、リレーションで利用できるようにしました。
 GEOアイテムのプロパティ画面の[詳細設定]タブにある、[周辺情報取得]タブで設定します。なお、本機
 能を有効にした場合は、周辺情報を確認するための周辺情報アイコンや、右クリックメニューの
 [周辺情報を取得]は利用できません。[#MB-104326]
・GEOアイテムにおいて、緯度経度情報を基にポイントをつなげて経路を描画する機能を追加しました。日時型
 の項目がある場合は、データチップに平均速度や最高速度なども表示できます。GEOアイテムのプロパティ画
 面の[経路情報設定]タブにある、[明細データから経路情報を生成]で設定します。[#MB-104776]
・GEOアイテムにおいて、経路情報の線の描画をアニメーションで表示できるようにしました。スライダーの操
 作で、始点から終点までの経路を順々に描画できます。再生ボタンを利用することもできます。GEOアイテム
 のプロパティ画面の[経路情報設定]タブにある、[アニメーション用のスライダーを利用する]で設定し
 ます。[#MB-104815]
・GEOアイテムにおいて、プロパティ画面の[詳細設定]タブに次の機能を追加しました。[#MB-102510-1]
 * エリアの色で[グラデーションで補完]を指定した際に、最大値および最小値を指定できるようにしまし
  た。色の濃淡が示す値の幅を任意に指定できます。[エリア]タブの[色]で設定します。
 * エリアの色で[個別指定]を指定した際に、色を個別で指定できるようにしました。エリアに表示する色を
  任意に追加できます。[エリア]タブの[色]で設定します。
 * データチップに表示する値項目の表示対象を選択できるようにしました。[データチップ]タブの
  [表示対象項目]で設定します。
 * レイヤーの表示項目のエリア名で、AND「/」やOR「」が使用されている場合に、先頭のエリア名のみ表示
  できるようにしました。[テキスト]タブの[表示項目]で設定します。
 * レイヤーの表示項目に[エリア値]を追加しました。エリア内の値を表示できます。なお、エリア値の
  フォーマットを設定することもできます。[テキスト]タブの[表示項目]で表示と非表示を、[値項目]
  でフォーマットを設定します。
 * 周辺情報を取得した際に、検索範囲を円で表示できるようにしました。周辺情報として取得した範囲を円で
  確認できます。[周辺情報取得]タブの[検索範囲を円で表示する]で設定します。
 * 同じポイントに複数のデータが表示されている場合に、重複ポイントのデータとして一覧で確認できるよう
  にしました。[クリック時アクション]タブの[重複ポイント]で設定します。
 * 背景に設定したGEOアイテムに対して、[前面に表示]の設定を追加しました。[他GEOアイテム統合]タブ
  で設定します。
 * 背景に設定したGEOアイテムに対して、[初期表示]の有無を指定できるようにしました。
  [他GEOアイテム統合]タブで設定します。本設定は[データパネル]タブの[他GEO表示設定]がオンの場
  合にのみ設定できます。
 * データパネルの表示項目の設定に[エリア/ポイント一覧絞り込み条件]と[経路データ読み込み]を追加
  しました。表示と非表示を切り替えることができます。[データパネル]タブで設定します。
 * データパネルを初期表示時に最小化できるようにしました。[データパネル]タブで設定します。
 * データパネルの表示項目の設定に[ポイント表示設定]を追加しました。データパネル上からポイントの値
  項目を切り替えることができます。[データパネル]タブで設定します。
 * データパネルの表示項目設定に[他GEO表示設定]を追加しました。背景に設定したGEOアイテムの表示と非
  表示を切り替えることができます。[データパネル]タブで設定します。
 * 地図上に表示される表示項目の設定に、地図の縮尺を示す[スケールバー]を追加しました。表示と非表示
  を切り替えることができます。[詳細設定]タブの[コンポーネント]で設定します。
 * 地図上で範囲内のデータを検索できる[範囲検索]を追加しました。範囲内のデータをリレーションのデー
  タとして利用したり、範囲内でヒットしたデータ件数を表示したりできます。[詳細設定]タブの
  [コンポーネント]で設定します。
 * マウスカーソルが指している地点の地名をGEOアイテム上に表示する[地名表示]を追加しました。日本全
  国の詳細な地名(日本語)、全世界の主要な地名(英語)を表示できます。表示される地名をリレーション
  のデータとして利用することもできます。地名の表示は[詳細設定]タブの[コンポーネント]で、地名の
  リレーションは[緯度経度から地名取得]タブで設定します。
 * 背景に設定したGEOアイテムのデータを、範囲検索時の検索対象にできるようにしました。背景に設定した
  GEOアイテムのデータをリレーションに利用できます。[範囲検索]タブの[背景GEO]で設定します。
・GEOアイテムにおいて、プロパティ画面の[ポイント設定]タブに次の機能を追加しました。
 [#MB-102510-2]
 * 重なり合うポイントを間引いて描画できるようにしました。[ポイント設定]タブの
  [重なり合うポイントを間引いて描画する]で設定します。
 * ポイントのシンプルのサイズを距離で指定できるようにしました。[距離で指定する]をオンにして、幅と
  高さをメートルで指定します。[シンプル]タブの[サイズ]で設定します。
 * ポイントのピンのサイズを変更できるようにしました。[小]、[中]、[大]から選択できます。
  [ピン]タブの[サイズ]で設定します。なお、MotionBoard Ver. 5.0で表示されていたサイズは[小]と
  なります。
 * ポイントのピンに形状を追加しました。[ピン]タブの[ベース画像]で設定します。
 * ポイント(シンプル、値、ピン)の色で[グラデーションで補完]を指定した際に、最大値および最小値を
  指定できるようにしました。色の濃淡が示す値の幅を任意に指定できます。[シンプル]タブの[色]、
  [値]タブの[背景]、[ピン]タブの[色]で設定します。
 * ズームイン/ズームアウトに合わせて、チャートやイメージを拡大/縮小できるようにしました。対象は、
  ポイントの棒、円、イメージです。指定回数分ズームイン/ズームアウトすることで、チャートやイメージ
  の大きさを倍または半分にできます。[棒]タブ、[円]タブ、[イメージ]タブの[拡大/縮小]で設定
  します。
 * ポイントで、棒の高さ、円のサイズ、バブルの大きさに対して最大値および最小値を指定できるようにしま
  した。指定した値に応じたサイズになります。[棒]タブの[高さ]、[円]タブの
  [値によるサイズ変更]、[バブル]タブの[サイズ]で設定します。

≪ボタンアイテム≫

 [GEOアクション]に[ズームレベル変更]を追加しました。ボタンをクリックするたびに、[ズーム変更値]
 で指定した数だけズームレベルを変更して、[対象GEO]に指定したGEOアイテムの地図を拡大/縮小できます。
 [#MB-103443]
・[ボタン種別]が[GEOアクション]のボタンアイテムについて、[GEOアクション]に
 [リレーションの実行]を追加しました。[対象GEO]にリレーションが設定されているGEOアイテムを指定す
 ると、ボタンのクリックでリレーションを実行できます。[#MB-105118]
・[ボタン種別]が[条件分岐]のボタンアイテムにおいて、プロパティ画面の[条件値]でもシステム変数
 を使用できるようにしました。[#MB-19394]
・ボタンアクションナビゲーターを追加しました。ボード編集時に、ボード上のボタンアクションの実行順序
 を確認したり、ボタンアイテムを編集したりできます。[#MB-102285]
・ボタンアイテムのプロパティにある[フォント設定]に、オプションとして
 [サイズに合わせて拡大縮小する]を追加しました。ボタンのサイズに合わせて、[表示テキスト]の文字
 サイズを自動で拡大/縮小できます。[#MB-102416]
・[ボタン種別]が[アイテム最大化]のボタンアイテムにて、[次に実行されるボタン]を設定できるよう
 にしました。これを設定すると、最大化したアイテムを閉じた後に、[次に実行されるボタン]に指定して
 いるボタンが自動実行されます。[#MB-103083]
・ボタンアイテムのプロパティ画面にて、[ボタン種別]が[チャートアクション]のときに、画面中央の
 [チャートアクション]で[EXCELに保存]を選択できるようにしました。対象のチャートが集計表の場合
 に、チャートデータをExcelファイルとして保存できます。[#MB-103318]
・[ボタン種別]が[アイテム最大化]のボタンアイテムにおいて、プロパティ画面に[余白]を追加しまし
 た。最大化したときの余白(画面のサイズ)を指定できます。[#MB-103319]
・一部のボタンアイテムにおいて、ボタンアイテム実行時に確認メッセージを表示するかどうかと、確認メッ
 セージの内容を指定できるようにしました。次のボタンアイテムが該当します。[#MB-103324-1]
 * [ボタン種別]が[チャートアクション]で、[チャートアクション]に[チャート入力データを保存]
  が指定されたボタンアイテム
 * [ボタン種別]が[サーバープログラム起動]のボタンアイテム
 * [ボタン種別]が[データベース入力]のボタンアイテム
 設定は、[新規アクションボタン]画面、またはボタンアイテムのプロパティで確認できます。
・ボタンアイテムの[ボタン種別]が次のものについて、[絞り込み]欄を追加しました。
 アイテム一覧に表示されるアイテムを、アイテム名の部分一致で絞り込んで表示できます。[#MB-103325]
 * [アイテム最大化]
 * [表示非表示切り替え]
 * [入力アイテムクリア]
 * [アイテムリロード]
・[ボタン種別]が[項目変更]のボタンアイテムで、プロパティ画面にある[行項目]、[列項目]、
 [集計項目]のそれぞれに、[変更対象にする]を追加しました。ボタンアイテムを実行したときに、項目
 の表示状態を維持するかどうかを指定できます。たとえば、行項目と列項目は現状を維持し、集計項目だけ
 を変更するといったことが可能です。[#MB-103335]
・[ボタン種別]が[明細アクション]のボタンアイテムにおいて、プロパティ画面の[明細アクション]に
 次の選択肢を追加しました。[#MB-103338]
 * [新規レコード作成](データソースに新規レコードを追加できます)
 * [データ更新](明細表アイテムに入力したデータを、データベースに反映できます)
 * [設定]([明細表の設定]画面を表示できます)
 * [切り替え](明細表アイテムの表示形式を切り替えることができます)
 * [最初のページ](最初のページを表示できます)
 * [前のページ](1つ前のページを表示できます)
 * [次のページ](次のページを表示できます)
 * [最後のページ](最後のページを表示できます)
・[ボタン種別]が[ユーザーシステム変数変更]のボタンアイテムで、複数の変数を変更対象に指定できる
 ようにしました。[#MB-103689-1]
・ボード編集モードにおいて、ボタンアイテムの右クリックメニューに[ボタンアクション実行]を追加し、
 そこからもボタンアイテムを実行できるようにしました。[#MB-103751]
・ボタンアイテムのプロパティ画面にて、[ボタン種別]が[チャートアクション]のときに、画面中央の
 [チャートアクション]で[集計結果検索]を選択できるようにしました。チャートメニューの[検索]で、
 [集計結果検索]を選択したときと同じ動作が行えます。なお、この設定をしたボタンアイテムは、
 +Mobileアプリケーションでは使用できません。[#MB-105240]
・ボタンアイテムの[ボタン種別]で[検索リセット]を選択できるようにしました。 全体検索や個別検索の
 適用結果をリセットして、適用前の状態に戻せます。[#MB-105119]

≪入力アイテム≫

・入力アイテムのカメラキャプチャーの設定に、[画像に緯度経度をExifとして保存する]を追加しま
 した。オンにすると、モバイル端末でGPS機能が有効な場合、撮影地点の緯度経度情報を画像のメタデータに
 保存できます。[#MB-103013-1]
・入力アイテムのカメラキャプチャーの設定に、[画像にコメントをExifとして保存する]を追加しま
 した。オンにすると、モバイル端末でGPS機能が有効な場合、画像撮影後にコメントを入力して画像のメタデ
 ータに保存できます。[#MB-103013-2]
・入力アイテムのカメラキャプチャーの設定に、[緯度情報を格納するシステム変数]と
 [経度情報を格納するシステム変数]を追加しました。画像の撮影地点の緯度情報と経度情報をシステム変数
 に格納できます。[#MB-103399]
・入力アイテムのリストボックスの設定に、[複数選択]を追加しました。オンにすると、初期値を複数指定で
 きます。[反映するシステム変数]を設定した場合は、半角カンマ区切りで複数の値が格納されます。
 [#MB-103655]
・入力アイテムのコンボボックス、リストボックス、ラジオボタンの設定に、[データプレビュー]ボタンを
 追加しました。[候補値]に[他データソース定義項目の値]を指定した場合に、他データソースの項目の
 実データを確認できます。[#MB-103665]
・入力アイテムのチェックボックスの設定に、[入力した値がチェック時の値と一致する場合ON]を追加しま
 した。指定した値と[チェック時の値]が一致する場合のみ、初期チェック状態がオンになります。値には
 システム変数も指定可能なため、動的に初期チェック状態を変更できます。[#MB-103794]
・入力アイテムのカメラキャプチャーの保存先に、[掲示板イメージ(専用アイテム)]と
 [掲示板イメージ(共有アイテム)]を追加しました。カメラキャプチャーで撮影した画像を、掲示板で使
 用できます。[#MB-103831]
・入力アイテムにトグルボタンを追加しました。チェックボックスと同様に、トグルボタンをオン/オフしたと
 きにシステム変数を変更したり、チャートにデータ入力したりできます。[#MB-103963]
・入力アイテムのカレンダーの設定に、[消しゴムの表示]を追加しました。オフにすると、カレンダーの右側
 に表示される消しゴムを非表示にできます。[#MB-105158]
・入力アイテムのプロパティの[チャート入力]から表示できる[データポイントを指定する]画面に、
 [タブで絞り込まれたデータのみ対象とする]を追加しました。オンにすると、チャートアイテムの表示項目
 がタブで絞り込まれている場合に、表示中のタブにのみデータを入力できます。オフにすると、すべてのタブ
 にデータが入力されます。[#MB-105316]

≪他アイテム≫

・[メニューエディタ]画面に、色の設定項目を追加しました。メニューアイテムの文字色や、表示形式がタブ
 の場合のタブの色を設定できます。[#MB-103238]
・テキストアイテムのプロパティ画面、リンクアイテム、メモに、[角丸め]を追加しました。各種アイテムの
 角を丸くできます。[#MB-103873]
・イメージアイテムのプロパティに、[画像の横寄せ方向]と[画像の縦寄せ方向]の2つを追加しました。
 アイテム内の画像の表示位置を指定できます。なお、[画像を拡大/縮小する]がオフのときに有効となりま
 す。[#MB-102698]
・コメント掲示板アイテムに、次の機能を追加しました。[#MB-102769]
 * 画像ファイルの追加
  [コメント登録]画面で、投稿するコメントに画像ファイルを添付できます。添付した画像は、コメント
  本文内にサムネイルで表示されます。
 * 添付ファイルの追加
  [コメント登録]画面で、投稿するコメントにファイルを添付できます。添付したファイルは、タイトル横
  のクリップアイコンからダウンロードできます。折り返し表示コメント本文が折り返し表示されます。
 * コメントの全件削除
  コメント掲示板アイテムの右上にある削除アイコンをクリックすると、コメントを全件削除できます。
 * 投稿者のホーム画面表示
  コメントの投稿者名をクリックすると、投稿者の情報をまとめて確認できる「ホーム画面」を表示できます。
  ※これに伴い、[コメント登録]画面でメールアドレスを設定した場合は、タイトル横のメールアイコンを
   クリックすると、設定されたアドレス宛にメールを作成できるようにしました。
 * 1ページに表示するスレッド数の調整
  コメント掲示板アイテムのプロパティの[1ページに表示するスレッド数]で、表示するスレッド数を変更
  できます。
・ガントアイテムのプロパティに、次の項目を追加しました。[#MB-103568/104259]
 * [初期サイズ]
  表示単位の選択肢に[6時間]を追加しました。
 * [開始と終了が同じ場合]
  開始と終了の日付(または時間)が同じ場合に、棒の代わりに表示する記号を選択できます。
 * [日付移動]
  期間の先頭や末尾や本日に移動するボタンを表示できます。
 * [拡大縮小]
  期間エリアと表示エリアを拡大/縮小するボタンを表示できます。
 * [時間軸操作の背景色]
  ボタンエリアの背景色を指定できます。
 * [行の背景色]
  行項目の奇数行と偶数行の背景色を指定できます。グラデーションの強さ、項目の枠線の表示有無、枠線の
  色も指定できます。
 * [行項目名]
  項目一覧エリアの項目値が表示領域に収まらない場合に、文字列を折り返して表示できます。
 * [行幅]
  項目値が表示領域に収まるよう最大行幅内で自動で幅を調整したり、固定幅で表示したりできます。
 * [データ]の[文字の不透明度]
  ガントの棒の上に表示される文字の不透明度を指定できます。
 * [データ]の[不透明度]
  ガントの棒の不透明度を指定できます。
 * [データ]の[グラデーションする]
  ガントの棒の色が上から下に向かってグラデーション表示できます。
 * [リレーションのデータ型]
  ガントアイテムから他のアイテムへのリレーションを作成する場合に、データの[開始日時]と
  [終了日時]を日付型の項目としてリレーション先に送信するか、日時型の項目として送信するか
  指定できます。
 * [カスタム色設定]の[インポート]と[エクスポート]
  特定データの棒の色を設定したカスタム色設定ファイルを、インポート/エクスポートできます。
・ガントアイテムで行項目を複数設定した場合に、項目の幅をドラッグして調整できる機能を追加しました。
 項目の右クリックメニューから[幅設定のクリア]を選択すると、項目の幅がデフォルトに戻ります。
 [#MB-103161]
・データソースエディタの[ガント]タブに、[時系列でソートする]を追加しました。ガントアイテムの行
 項目を[開始日時]に配置された項目の昇順に表示できます。[#MB-104261]

≪データソース≫

・異なるデータソースの明細データをJOINやUNIONで結合する機能「モデル」を追加しました。特別なデータ
 加工をすることなく、MotionBoard上で論理的にデータを結合でき、また、そのデータはチャートアイテムや
 明細表アイテムなどに利用できます。[#MB-102604]
・データソースエディタの[分析]メニューに[ABC分析]を追加しました。
 ABC分析は、在庫管理や販売管理、製造業などで利用される分析手法です。数値の大きい順に累積構成比を
 計算し、その構成比の上位0~80%をA、80~90%をB、90~100%をCというようにランクを付けることで、どの
 項目(ランク)に重点を置いて管理すべきかを分析できます。[#MB-102798-1]
・データソースエディタの[分析]メニューに[デシル分析]を追加しました。
 デシル分析は、顧客分析やマーケット分析などで利用される分析手法です。たとえば、全顧客を売上金額の
 大きい順に10等分してランク付けし、各ランクの傾向から「上位20%が売上の80%を占めている」といったこ
 とを分析できます。[#MB-102798-2]
・データソースエディタの[分析]メニューに、[トライアルリピート分析]を追加しました。商品の購入デ
 ータから、同一顧客が同一商品を複数回購入しているかどうかを分析し、新製品の市場への浸透度合いや顧
 客の定着度などを把握できます。なお、接続先のデータソースがインメモリテーブルの場合に設定できます。
 [#MB-103351]
・データソースエディタの[分析]メニューに、[バスケット分析]を追加しました。商品の購入履歴から、
 特定の商品と一緒に購入される可能性が高い商品を抽出できます。なお、接続先のデータソースがインメモ
 リテーブルの場合に設定できます。[#MB-9618]
・データソースエディタの[ランキング設定]画面で、[ランキングターゲット]の[項目値]にシステム変
 数を指定できるようにしました。[#MB-102330]
・ABC分析機能の追加に伴い、チャートエディタの[チャートエリア]タブにある[折れ線・棒系設定]-
 [パレート図]に、次の3つの設定項目を追加しました。ABC分析を設定しているデータソースにてパレート
 図を表示する場合に、背景の表示方法や色を指定できます。[#MB-103104]
 * [ABC分析スコアルールを背景に描画する]
 * [ABC分析スコアルールの背景を囲む]
 * [ABC分析項目ごとの領域の色]
・データソースがインメモリテーブルの場合、集計方法として次の統計関数を利用できるようにしました。
 データソースエディタの[チャート]タブに配置された集計項目の[集計方法]で選択できます。
 [#MB-8083]
 * 最頻値
 * 中央値
 * 第1四分位数
 * 第3四分位数
 * 分散
 * 母集団分散
 * 標準偏差
 * 母集団標準偏差
・データソースエディタの[カスタム項目 作成]画面にある[計算式]で、システム変数を使用できるように
 しました。なお、システム設定の[全般]画面にある[カスタム項目でシステム変数を利用する]をオンに
 する必要があります。[#MB-9615]
・[検索情報表示]画面に表示される項目に、[行数]、[列数]、
 [データポイント数]を追加しました。[#MB-9062]
・データソースエディタの[RFM分析設定]画面にて、[顧客項目]や[購買日項目]などの項目を指定する設
 定に対してプレビューアイコンを追加しました。指定した項目の値を確認できます。[#MB-103184]
・次のデータをデータソースとして活用できるようにしました。データソースエディタの[データソース選択]
 画面にある[接続先]で[system datasources]を選択すると、いずれかのデータを格納したデータソース
 を選択できます。[#MB-103212]
 * ボード定義の一覧(作成済みのボードの名前や作成日時などのデータ)
 * ボードへのアクセス履歴(ボードに、いつ誰がアクセスしたのかのデータ)
 * ボードへの累計アクセス数(ボードへの総アクセス数のデータ)
・他の集計項目値を条件にアラートを表示できるよう、[アラート設定]画面に[比較対象]を追加しました。
 [比較対象]に選択した項目を基に、アラート条件を満たすかどうかを判定します。アラート対象となるの
 は、[項目名]で選択された項目です。[#MB-103226]
・データソースエディタの[基本項目設定]画面の[チャートの配置設定(集計項目)]に、[前年集計]を
 追加しました。年の情報を含む項目を行や列に配置している場合に、前年の集計値を取得できます。これに
 より、たとえば、[前年集計]を設定している項目を事後計算項目に使用することで、前年同月比の設定が
 スムーズに行えます。[#MB-103956]
・データソースエディタの[項目一括編集]画面に、[別名一括入力]ボタンを追加しました。項目名に対応
 する別名を一括で入力できます。[#MB-103355]
・カスタム項目の計算式で「GETTIME()」を指定した場合に、1970年1月1日 0時0分0秒から現在までのミリ秒を
 取得できるようにしました。[#MB-103259]
・データソースエディタの[明細表]タブに、[明細表集計を有効にする]を追加しました。
 この設定を有効にすると、同じ値のデータがまとめられて1件のデータとして集計されます。ここでいう
 「同じ値のデータ」とは、集計方法が指定された項目(集計対象項目)以外の項目値が同じものを指します。
 集計方法として、次のものを選択できます。[#MB-103275]
 * 合計
 * 平均
 * 件数
・[マスター項目 作成]画面に[不一致時の表示値]を追加しました。結合項目で一致しないデータが存在す
 る場合、そのデータを表示するか「」を表示するかを選択できます。なお、「」として表示した
 場合、 検索条件にて不一致データの検索はできません。また、リレーション設定の「検索」のアクションに
 よる検索もできません。[#MB-102138]
・データソースエディタの[リンク/イメージ設定]画面にある、[リンクURL]や[イメージURL]に[選択]
 ボタンを追加しました。[選択]ボタンは[内部パス]を指定している場合に使用できるもので、クリック
 するとダイアログが表示され、共有フォルダー内のファイルを選択できます。[#MB-102539]
・データソースエディタの[基本項目設定]画面の[チャートの配置設定]に、[ソート項目]を追加しまし
 た。他の項目の値を基準に、行や列を並び替えできます。また、Dr.Sum EAの基本項目(TextOLAP型の項目を
 除く)の場合に設定できます。[#MB-102598]
・データソースエディタの[データソース選択]画面に[項目マッチング]を追加しました。既存のデータソ
 ース定義で、現在のデータソースとは異なるデータソースを選択した際に、現在のデータソースの項目に
 対する設定を、選択し直したデータソース内のどの項目に引き継ぐかを設定できます。[#MB-102974]
・[事後計算項目 作成]画面に[計算結果がNULLの場合0とする]を追加しました。計算結果がNULL値の場合
 に、「0」に置換できます。また、 事後計算関数として「NVL」関数を追加しました。NULL値を任意の値に
 置換できます。[#MB-102985]
・データソースエディタの[ランキング設定]画面にて、[表示数]に設定できる最大値を100から1000に拡張
 しました。[#MB-104582]

≪スナップショット≫

・[スナップショット保存先管理]画面の[新規作成]ボタンをクリックしてデータソースを選択した後に、
 [スナップショット保存先テーブル設定]画面を表示するようにしました。スナップショット保存先
 (のテーブル)で使う項目を取捨選択したり、項目の設定を変更したりできます。また、カスタム項目の作
 成も可能です。[#MB-9357]
・[スナップショット保存先詳細設定]画面の[繰り返しタイプ]に[毎時]を追加しました。スナップショ
 ットの実行間隔を、時間単位で指定できるようになります。[#MB-18188/01238]
・[スナップショット保存先管理]画面にて、右クリックメニューから、スナップショット保存先設定のダウ
 ンロードとアップロードをできるようにしました。[#MB-102752]
・使用中のすべてのデータが複製される「レプリケーションのスナップショット」を追加しました。
 「明細のスナップショット」との違いとして、持てるデータの履歴数が1つ(1世代分)だけとなります。
 初回データ投入時には時間を費やしますが、以後は差分(更新や新規のデータ)だけが追加されていくため、
 データの処理速度の向上やデータの格納時間短縮を期待できます。[#MB-103369]
・次のデータベースを、スナップショット保存先として設定できるようにしました。[#MB-103370]
 * Oracle Database
 * Microsoft SQL Server
 * MySQL
 * PostgreSQL
・共有データソースを使用するチャートアイテムにおいて、ショートカットボタンの[データ格納]-
 [スナップショット]を選択したときに、スナップショットの種類(明細または集計結果)を選択できるよ
 うにしました。「明細のスナップショット」だけでなく「集計結果のスナップショット」の出力条件も、
 ショートカットボタンから設定できるようにしました。[#MB-103396]

≪検索条件、フィルター≫

・全体検索条件を複数作成できるようにしました。[ボード管理]画面の[全体検索設定]タブで検索条件ごと
 にタブを作成して、検索対象とするアイテムを管理できます。全体検索条件を複数作成すると、[検索]
 メニューの[全体検索]に、検索条件名のサブメニューが表示されます。これによって、たとえば「年月」の
 検索条件はすべてのチャートに適用し、「地域」の検索条件は特定のチャートにのみ適用する、といった設定
 が可能になります。[#MB-6165]
・日付型または日時型のデータを期間で検索する場合の検索候補値として、次の値を追加しました。データソ
 ースエディタの[検索設定]画面で設定できます。[#MB-102339]
 * [年月]に、[先々月]、[再来月]、[先々月から今月]、
  [今月から再来月]を追加
 * [週]に、[先々週]、[再来週]、[今週および来週]、
  [今週および先週]、[先々週から今週]、[今週から再来週]を追加
・検索条件の設定画面にて、[検索値の指定方法]で[期間]を選択した場合の[検索候補値]欄内に、
 [表示]列を追加しました。候補値ごとに、検索画面の選択肢として表示するかどうかを指定できます。
 [#MB-102340]
・検索条件の設定画面で、[選択値に「すべて」を表示する]の隣に[改行する]を追加しました。
 [検索値の指定方法]で[ラジオボタン]または[チェックボックス]を選択した場合に表示される設定項
 目となり、「すべて」を示す値と他の候補値を改行で区切って表示するかどうかを指定できます。
 [#MB-103192]
・データソースエディタの検索条件の設定に、すべての値を示す選択肢(デフォルトでは[すべて])
 の表示文字列を変更できる設定を追加しました。選択肢が店舗名の場合は「全店舗」とするなど、条件に
 応じた文字列を表示できます。[検索値の指定方法]で、[コンボボックス]、[リストボックス]、
 [複数リストボックス]、[ラジオボタン]、[チェックボックス]、[期間]を選択した場合に設定可能
 です。[#MB-103220]
・フィルターアイテム、フィルターコンポーネント、検索コンポーネントのプロパティに、背景色やフォント
 に関する設定を追加しました。[#MB-103341]
・フィルターコンポーネントと検索コンポーネントのプロパティに、[アイテム幅に合わせる]を追加しまし
 た。オンにすると、入力フォームをアイテムの幅に合わせて表示できます。[#MB-105155]
・フィルターコンポーネントのプロパティに、[「すべて」を表示]を追加しました。値の選択肢に
 [すべて]を表示するか指定できます。[#MB-105156]

≪リレーション≫

・[リレーション設定画面]に[ソート時アクション]を追加しました。ドロップダウンリストから
 [ソート同期]を選択した場合、リレーション元のアイテムをソートすると、リレーション先のアイテムも
 ソートされます。リレーション元とリレーション先が、両方ともチャートアイテムの場合のみ設定できます。
 [#MB-102326]
・複数のデータポイントの値を、リレーションの対象にできる機能を追加しました。対象の機能は、次のとおり
 です。[#MB-102990]
 * チャートエディタの[チャートエリア]タブにある、[共通設定]-[全般]-[範囲選択、複数選択時に
  含まれるデータをリレーションデータとする]
 * 明細表アイテムのプロパティにある[複数選択リレーション]
・[リレーション設定画面]に[スクロール時アクション]を追加しました。ドロップダウンリストから
 [スクロール同期]を選択すると、リレーション元のアイテムのスクロールや、チャート右下のスライダー
 でのズームによって、リレーション先のアイテムもスクロールまたはズームします。リレーション元とリレ
 ーション先が、両方とも折れ線または棒系チャートの場合のみ設定できます。[#MB-103416]
・[表示]メニューの[リレーション]に、[一覧表示]を追加しました。選択すると[リレーション一覧]
 画面が表示され、ボード上に作成されているリレーションを確認、編集、削除できます。[#MB-103570]
・[リレーション設定]画面に、[アクションボタン]を追加しました。リレーション実行時に、実行するボ
 タンを指定できます。[#MB-103936]

≪システム設定≫

・システム設定の[全般]画面に[ウィンドウタイトル]を追加しました。Webブラウザーのウィンドウタイト
 ルを変更できます。[#MB-102327]
・[システム設定]画面の[変数]画面に、[カテゴリ]と[上書き]を追加しました。[カテゴリ]では、
 変数のカテゴリ名を指定することで、変数を分類できます。また、[上書き]では[許可]、
 [外部変数のみ禁止]、[禁止]のいずれかから選択し、値の上書きを許可するかどうかを設定できます。
 [#MB-102460]
・システム設定の[データソース]画面に、次の機能を追加しました。[#MB-102589-2]
 * 一覧に表示されたボードへ遷移できるようにしました。
 * 一覧に表示されたデータソースをデータソースエディタで開けるようしました。
 * 一覧に表示された内容を、CSVファイルとしてダウンロードできるようにしました。
・システム設定の[指名ユーザー]画面に、[グループ]を追加しました。ユーザー一覧に表示されるユーザー
 を、グループで絞り込んで表示できます。[#MB-102753]
・システム設定の[指名ユーザー]画面において、[ドメイン]で選択したドメインに存在しないまたは無効な
 ユーザーIDに、下線を表示するようにしました。また、下線が表示されたユーザーを、まとめて指名ユーザー
 一覧から削除できる[指名ユーザーを整理する]ボタンを追加しました。[#MB-102754]
・システム設定の[タスク]画面に[通知]タブを追加しました。タスクの状態(ステータス)をメールで通知
 する設定ができます。[#MB-102762]
・システム設定の[ロール]画面に、[コピーして新規作成]ボタンを追加しました。ロール一覧で選択した
 ロールの権限をコピーして新しいロールを作成できます。[#MB-102763]
・システム設定の[タスク]画面で、タスクの開始日時と終了日時を確認できるようにしました。
 [#MB-102808]
・システム設定の[タスク]画面に、[設定一覧]タブを追加しました。MotionBoardサーバーに設定されてい
 るすべてのタスクを一覧で確認できます。また、従来の[タスク]画面の表示内容(現在から3時間以内に
 実行されるタスクと、過去1週間で実行されたタスクの一覧)は[履歴]タブとして表示されるようにしまし
 た。[#MB-102980]
・システム設定に[変更通知]画面を追加しました。システム設定が変更された場合に、あらかじめ決められ
 た送信先にメールを送信する設定ができます。[#MB-103101-1]
・システム設定の[ロール]画面に表示される権限に、[システム設定(XXX)](XXXにはシステム設定の画
 面名が表示されます)を追加しました。システム設定の特定の画面のみ操作を許可する権限です。たとえば、
 [システム設定]の権限を持たないユーザーに[システム設定(全般)]権限を付与した場合、システム設
 定の[全般]画面のみ操作が可能になります。[#MB-103217]
・[システム設定]画面に[PV]画面を追加しました。全ボードのPVや足跡の情報を一覧表示したり、データ
 を一括出力したりできます。[#MB-103223]
・[システム設定]の[インポート]実行時に、同じバージョンのMotionBoardからエクスポートされた設定情
 報ファイルかどうかをチェックするようにしました。インポートを実行するには、バージョン表記の最初の
 5.5.XX(XXには数字が入ります)までが一致する必要があります。[#MB-103366]
・[システム設定]の[メーリングリスト]画面に、[一括登録]ボタンを追加しました。 このボタンをクリ
 ックすると[一括登録]画面が表示され、複数のメーリングリストを同時に作成できます。[#MB-103455]
・[システム設定]の[全般]画面の[セキュリティ]に、[URLパラメーターでシステム変数を利用する]を
 追加しました。チェックボックスをオンにすると、URLパラメーターとPOSTパラメーターにシステム変数の設
 定が可能になります。[#MB-103537]
・[システム設定]の[インポート]をクリックして表示される[インポート対象選択画面]、および
 [エクスポート]をクリックして表示される[エクスポート対象選択画面]に、すべてのカテゴリを選択で
 きるチェックボックスを追加しました。[対象]の右にあるチェックボックスをオン/オフにすると、すべて
 のカテゴリをインポート/エクスポートの対象にするか、非対象にするかを設定できます。[#MB-103544]
・[システム設定]の[メールサーバー]画面にある[タイプ]に、[SMTP(TLS認証あり)]を追加しました。
 [タイプ]から[SMTP(TLS認証あり)]を選択すると、Office 365やGmailのSMTPサーバーへ接続できます。
 [#MB-103555]
・システム設定の[変数]画面に[NULLの表現]を追加しました。ユーザーシステム変数の値がNULL値の場合
 に、アイテムに表示されるユーザーシステム変数の値を[< NULL >]または[空文字]のいずれかから選択
 できます。[#MB-103653]
・システム設定の[ロール]画面に表示される権限に、[WEBAPI]を追加しました。これに伴い、システムロ
 ール「管理者」に[WEBAPI]の権限を追加しました。[WEBAPI]の権限を持つユーザーは、全Web APIを実行
 できます。[#MB-103890]
・システム設定の[ロール]画面に表示される権限に、[パスワード変更]を追加しました。これに伴い、
 システムロール「管理者」、「ボード管理者」、「一般ユーザー」、「閲覧ユーザー」に[パスワード変更]
 の権限が追加されました。
 [パスワード変更]の権限を持つユーザーは、MotionBoardサーバーへのログインパスワードを変更できま
 す。[#MB-104136-1]
・システム設定の[ロール]画面に表示される権限に、[MotionBoardAgentダウンロード]を追加しました。
 これに伴い、システムロール「管理者」、「ボード管理者」に[MotionBoardAgentダウンロード]の権限が
 追加されました。
 [MotionBoardAgentダウンロード]の権限を持つユーザーは、メニューバーの[管理]ー
 [MotionBoard Agent ダウンロード]から、MotionBoard Agentのインストーラーをダウンロードできます。
 [#MB-104136-2]
・[システムメッセージ]画面に次のタブを追加し、ログイン画面とログイン後の画面のそれぞれにシステム
 メッセージを表示できるようにしました。[#MB-103947]
 * [ログイン前メッセージ]タブ
 * [ログイン後メッセージ]タブ

≪システム変数≫

・次の箇所にて、URL やパラメーターの[値]に「${システム変数名}」を指定できるようにしました。
 [#MB-18090-2]
 * リンクアイテム([リンク追加]画面、アイテムプロパティ)
 * リンクボタン([新規リンク]画面、アイテムプロパティ)
 * リンクボード([リンクボード設定]画面)
・各所に、システム変数の指定補助機能を追加しました。アイテムプロパティの[名前]や、[検索設定]画面
 の[値]などにて、入力欄の右端にアイコンが表示されるようになります。アイコンをクリックすると
 [システム変数]画面が表示され、既存のシステム変数を選択して入力欄に挿入したり、システム変数を新規
 作成したりできます。[#MB-103153]
・[集計表のスタイル]画面で、システム変数を指定できるようにしました。システム変数を指定できる項目は、
 次のとおりです。[#MB-103234]
 * [カスタム行スタイル]タブの[行名]
 * [カスタム列スタイル]タブの[列名]
 * [カスタムセルスタイル]タブの[セル名]
・データソースエディタの[グループ項目 作成]画面の[整数ステップ]にある、[範囲]と[ステップ]で
 システム変数を使用できるようにしました。[#MB-105151]

≪外部データベースとの連携≫

・接続先がOracle Database、Oracle Exadata、Oracle RACのいずれかの場合に、[外部接続]画面の
 [基本情報]タブに[Oracleのユーザーで認証する]を追加しました。Oracleからデータを取得するユーザー
 を、MotionBoardのローカルユーザー(admin@local以外)にするか、[サーバー管理者ID]のユーザーにする
 かを選択できます。なお、次の注意点があります。[#MB-8600]
 * MotionBoardのローカルユーザーでデータを取得する場合、そのユーザーと同名のユーザーが接続先の
  Oracleに登録され、データ取得に必要な権限が設定されている必要があります。
 * Oracle Database 9iでは使用できません。
・Excelファイルをデータソースとして利用する際の、Excelファイルの読み込み設定をMotionBoard上でも設定
 できるようにしました。[#MB-18520]
・接続先のデータソースがHitachi Advanced Data Binder(HADB)の場合に、カスタム項目を行または列に配
 置できるようにしました。[#MB-102721]
・[外部接続]画面の[データしきい値]タブにおいて、次の項目の最大値を拡張し、1048576行のデータがあ
 るExcelファイルをデータソースとして読み込めるようにしました。[#MB-19328]
 * [対象データの最大総件数]の、[チャートデータ]と[明細表]
 * [警告]-[明細表]-[行数]
 * [最大集計]-[明細表]-[行数]
・Dr.Sum EA Ver. 4.1の機能「総件数の算出をスキップする」との連携に対応しました。Dr.Sum EA Ver. 4.1に
 接続してチャートアイテムを表示する場合に、MotionBoardのシステム設定にある[外部接続]-
 [データしきい値]-[対象データの最大総件数]-[チャートデータ]の設定内容によって、
 [検索情報表示]画面に[総データ件数]が表示されるか表示されないかが変わります。
 オンの場合は、Dr.Sum EAの設定に依存せず常に件数が表示され、オフの場合は、Dr.Sum EAの設定に従って
 表示内容が変わります。[#MB-103578]
・グループ単位でExcelテンプレートをインポートまたはエクスポートできるようにしました。[#MB-18800]
・次の外部データベースと接続する際に、SSL暗号化通信を使用できるようにしました。[#MB-103420]
 * Oracle Database
 * Oracle Exadata
 * Oracle RAC
 * Microsoft SQL Server
 * MySQL
 * PostgreSQL
 * Greenplum Database
 * Amazon Redshift

≪+Mobileアプリケーション、MotionBoard Agent、MotionBoard Client≫

・+Mobileアプリケーションにおいて、リンクアイテムや、データソースエディタの[リンク/イメージ設定]
 などのリンク機能から、他のアプリケーションを起動できるようにしました。先頭文字が、「http://」、
 「https://」、「ftp://」以外から始まる URLにアクセスできるようになります。[#MB-18090-1]
・+Mobileアプリケーションのログイン起動オプションとして,変数に値を格納する「dv-変数名=変数値」を使
 用できるようにしました。たとえば,ログイン直後にボードを開く際,変数の値で検索した結果を表示できま
 す。[#MB-18336]
・+Mobileアプリケーションでも、PV数やアクセス日時などの情報を確認できるよう、[高度な操作]メニュー
 に[PVと足跡]を追加しました。[#MB-103859]
・+Mobileアプリケーションの[高度な操作]メニューに[ボード情報]を追加しました。現在開いているボー
 ドの、ボードパスやボードの更新日などの情報を確認できます。[#MB-103860]
・+Mobileアプリケーションの[ユーザー設定]-[モバイルキャッシュ]に、[更新検知]を追加しました。
 オンにすると、ボードを開いたときに現在のボードの内容とキャッシュの内容に差異がある場合、最新のデ
 ータを取得するかを確認する画面が表示されます。[#MB-103905]
・モバイルのスタートナビに、閉じるボタンを追加しました。タップすると、スタートナビを閉じることがで
 きます。[#MB-102423]
・MotionBoard Agentの[設定]画面に、[リトライ回数]を追加しました。自動アップロードに失敗した場合
 に、リトライする回数を0~9で指定できます。[#MB-102766]
・プロキシサーバーへの接続が必要な環境下でも、MotionBoard Agentを使用できるようにしました。
 MotionBoard Agentのインストール時に、プロキシサーバーのIPアドレスやポート番号を指定できます。
 [#MB-103799]
・MotionBoard Agentの[設定]画面に[更新判定]を追加しました。アップロード対象のファイルの内容が
 更新されている場合に自動アップロードするのか、ファイルの更新日時が異なるだけで自動アップロードす
 るのかを指定できます。[#MB-104744]
・MotionBoard Clientの起動時に、自動的に最新版へ更新されるようにしました。[#MB-103977-2]

≪コマンドラインツール≫

・コマンドラインツールに、次のコマンドを追加しました。[#MB-18191/01237]
 * 「directory export local user」
  ユーザーID、ユーザー名の一覧を、CSVファイルとしてエクスポートします。
 * 「directory export local group」
  グループIDの一覧を、CSVファイルとしてエクスポートします。
 * 「directory export role」
  ロールID、ロール名、システムロールのフラグ(当該ロールがシステムロールかカスタムロールか)の
  一覧を、CSVファイルとしてエクスポートします。
 * 「directory export local groupuserrelation」
  ローカルグループとユーザーの紐付(関連付け)の一覧を、CSVファイルとしてエクスポートします。
 * 「directory export local grouprolerelation」
  グループID、ロールIDの紐付(関連付け)の一覧を、CSVファイルとしてエクスポートします。
 * 「board export deflist」
  ボードパス、作成日時、更新日時の一覧を、CSVファイルとしてエクスポートします。
・コマンドラインツールに、ボードに保存されている全体検索と個別検索の検索条件値を初期化するコマンド
 「board reset searchcondition」を追加しました。[#MB-102360]
・コマンドラインツールに、「いいね!」の投票数の情報をCSVファイルとしてエクスポートするコマンド
 「boardlike export csv」と、「いいね!」の投票数の情報をリセットするコマンド「boardlike reset」
 を追加しました。[#MB-103102]
・コマンドラインツールの、ユーザーのスタートページを設定するコマンド「user set startpage」に、
 パラメーター「target」を追加しました。指定するパラメーター値によって、スタートページの設定対象を
 PCからログイン、モバイル端末からログイン、またはその両方の場合のいずれかを指定できます。
 [#MB-103274]
・コマンドラインツールに、ユーザーのプロフィール画像を設定するコマンド「user set profileimage」を
 追加しました。[#MB-103424]
・コマンドラインツールに、ログイン禁止時間帯の設定の有効/無効を変更するコマンド「set login enabled」
 を追加しました。[#MB-104412]
・コマンド「user set startpage」で、[ホーム]画面をスタートページに設定できるようにしました。
 [ホーム]画面をスタートページに設定するには、スタートページ情報CSVファイルの項目
 「スタートページ」に、「」を指定します。[#MB-103978]

≪Web API≫

・「レプリケーションのスナップショット」の追加に伴い、Web API
 「CSVファイルのスナップショット直接取り込み」でレプリケーションのスナップショットを指定できるよう
 にしました。[#MB-104858]
・全Web APIで指定可能なパラメーターとして、変数に値を格納する「dv-変数名=変数値」を使用できるように
 しました。たとえば、検索条件の候補値として変数値を指定し、その検索結果が反映されたイメージチャート
 を取得できます。なお、システム設定の[全般]画面にある[URLパラメーターでシステム変数を利用する]
 をオンにする必要があります。[#MB-103429]
・ログをダウンロードできるWeb APIを追加しました。[#MB-103933]

≪その他≫

・Adobe Flash Playerのインストールを促す画面を、任意の画面に変更できるようにしました。対象の画面は、
 Adobe Flash Playerをインストールしていない環境からMotionBoardにアクセスしたときに表示されるもの
 です。[#MB-103942]
・ユーザーのプロフィールやお気に入りボードなど、ユーザーに関するさまざまな情報を表示できる
 「ホーム画面」を追加しました。メニューバーのユーザーIDをクリックするか、スタートナビの
 [ホーム]タブをクリックすると、ホーム画面が表示されます。
 モバイルでは、スタートナビのボタンバーの[ホーム]をタップすると、ホーム画面が表示されま
 す。[#MB-103043]
・ユーザーごとの専用フォルダー[マイボード]を追加しました。ボードツリーに表示される[マイボード]
 配下にボードを作成すると、他のユーザーからは参照されないボードを作成できます。ただし、管理者ユー
 ザーはボードツリーに[マイボード(全ユーザー)]が表示され、すべてのユーザーのマイボードを参照で
 きます。[#MB-103228]
・[ユーザー設定]画面に、[使い方のヒント]を追加しました。オンにすると、ボード編集画面で使い方な
 どを示す吹き出しが表示されます。[#MB-102437]
・[ユーザー設定]画面に、[ファイル数やフォルダー数を表示する]を追加しました。
 オフにすると、ボードツリーのフォルダー名の後の、フォルダー数やボード数を非表示にできます。
 [#MB-102495]
・スタートナビや[共有アイテム管理]画面から表示できる[履歴]画面に、[履歴を削除]ボタンを追加し
 ました。一覧でオンにした履歴を削除できます。[#MB-102764]
・拡張プログラムのクラス「DataSourcePluginRuntimeInfo」に、メソッド「getDateFormat」とメソッド
 「getTimestampFormat」を追加しました。システム設定の[全般]タブにある、[フォーマット]の
 [日付表示]や[時刻表示]の設定内容を取得できます。[#MB-103658]
・拡張プログラムに明細データ取得時実行プログラムを追加しました。明細表アイテムやGEOアイテムなどの
 明細データを変更できます。また、明細表アイテムからダウンロードするCSVファイルのデータを変更する
 こともできます。[#MB-103470]
・クラスター関連のログ情報を追加しました。CONFIGファイルの「inter_connect_logLevel」を「INFO」もし
 くは「WARN」に変更することで、「interconnect-yyyymmdd-n.log」に「マスターノードの変更」、
 「ノード一覧の変更」、「新規コネクションの作成成功」のログ情報が出力されるようになります。
 [#MB-18088]
・操作ログで出力される情報の「操作内容」に、ファイル操作(作成、更新、削除)を追加しました。
 [#MB-103682]
・データソースからのデータ取得に関する「データアクセスログ」を追加しました。データアクセスログには、
 「どのユーザーが」、「いつ」、「どのデータソースに対して」、「どの項目を」、「どの検索条件で」
 データの取得をしたのかの履歴が出力されます。[#MB-102704]

 

その他の対応事項

その他の対応事項は、下記URLにてご覧いただけます。(要ログイン)

https://customer.wingarc.com/support/DownloadReleaseNote