Dr.Sum EA MotionBoard 3.0aから3.0SP1へのバージョンアップ履歴

公開日時:2013/02/26 20:00 記事番号:000009459
製品ブランド:MotionBoard

機能追加事項

・アプリケーション全体
 - Dr.Sum EA 3.0 SP3に対応しました。
・ボード全体 (スタートナビ、ボードツリー、アイテムナビ、メニュー)
 - MotionBoard内に外部のWebページを表示できるリンクボードを追加しました。
 - システム全体ではなく、開いたボードのみで利用することができるボード専用アイテムとして次のものを追加しました。
  データソース、CSVファイル、チャート、明細、イメージ、テキスト、リンク、コメント掲示板
 - ページガイド機能を追加しました。
 - リレーション機能を拡張し、チャートをクリックする等のアクションで検索等ができるようにしました。
 - ウインドウのレイヤーの順番を変更・保存できるようにしました。
 - ウインドウを複数選択した際に最大化ができるようにしました。最大4画面まで選択して最大化ができます。
 - ボード編集モードのアイテムツールバーにアイテム作成機能を追加しました。
 - グラフィック描画モードにテキストツール機能を追加しました。
 - ユーザ閲覧モード時はアイテムナビゲータにアイテムを表示しないようにする機能を追加しました。
 - メニューアイテムを表示した際に、「ボード定義名」と「ユーザ操作」の間をセパレータで区切りました。
 - PDF出力のエリア選択で一度確定した範囲をドラッグ操作で調整できるように対応しました。
 - ボード編集モード時に画面下部に表示される各ボタンをメニューからもアクセスできるように対応しました。
・チャート
 - 集計表の行、列、セルごとにスタイルを設定できる機能を追加しました。
 - 集計表の行、列に行項目か列項目のどちらを表示するか選択できるようにしました。
 - 集計表の合計、総合計それぞれの表示状態を指定できるようにしました。
 - 右クリックメニューからExcelにダウンロードできる機能を追加しました。
 - 右クリックメニューからアラートの点滅、アラートの表示を切り替える機能を追加しました。
 - 左クリックに右クリックメニュー項目を割り当てる機能を追加しました。
 - [分割時並び順切替ボタン]の選択肢に、自由に配置設定できる「カスタム」を追加しました。
 - チャートメニューからデータソースエディタを開く機能を追加しました。
 - 散布図・バブルチャートでポイントの遷移を矢印で表現する機能を追加しました。
 - ウォーターフォールチャートに集計項目比較モードを追加しました。
 - 集計結果に対して「行」「列」「行&列」で絞り込む機能を追加しました。
 - ドリルダウン(シナリオ)実行時に指定したチャート定義を表示する機能を追加しました。
 - 集計表のセル内の文字列を部分選択できるように対応しました。
 - 右クリックメニューの並び順を変更する際、行、列同時に行えるように対応しました。
 - 円チャート、レーダー、ゲージで並び順を変更できるように対応しました。
 - ダウンロードする CSV に予測データが含まれるように対応しました。
 - ウォーターフォールチャートで、データチップの表示に対応しました。
・明細
 - メニューに行の高さを変更できるスライダーを追加しました。
 - 明細エディタから明細メニューボタンの表示/非表示を指定可能としました。
・テキスト
 - テキストの背景色を自由に選択できるように対応しました。
・フィルター
 - 右クリックメニューにタブを非表示にする機能を追加しました。非表示にしたタブで選択された内容は維持されます。
・リンク
 - 編集機能を追加しました。
 - リンクアイテムの背景色を自由に選択できるように対応しました。
・コメント掲示板
 - 返信機能・編集機能を追加しました。
 - 親コメントのみ表示、全コメント表示のビューモードを選択できる機能を追加しました。
・ボタン
 - 以下のボタンアイテムを追加しました。
  アイテム最大化、表示非表示切替、ボード定義切り替え、ボードスクロール、PDF出力、リンク、サーバープログラム起動
・データソース
 -結合条件として「完全外部結合」「左外部結合」「完全内部結合」「内部結合」を指定できる結合データソースの作成を可能にしました。 データソースを最大4つまで指定し、各データソースのクロス集計結果の結合をおこないます。
 - グループ項目の作成を可能にしました。指定した項目に含まれるデータを任意にグルーピングして、チャートに表示することが可能です。
 - 検索条件で「他データソースの項目値」を指定している場合に、「直接入力」または「他の項目」が指定されているときのみ、 参照先の他データソースの検索条件を有効にすることを可能にしました。
 - チャートプレビュー、明細プレビュー、一項目のデータのプレビュー機能を追加しました。
 - アラート条件の複数指定と、アラート箇所の点滅の色を設定する機能を追加しました。
 - 明細のソート優先順を設定できるようにしました。
 - 別データソースへのドリルダウン、ドリルスルーを実行する機能を追加しました。
 - 事後計算項目の計算式に、他の事後計算項目を使用できるように対応しました。
 - 事後計算項目の集計方法にて、合計を事後計算で算出するか、集計方法を使用して算出するかを選択可能にしました。
 - アラート条件に集計項目以外の行項目、列項目を指定できるように対応しました。
 - アラート条件に優先度のレベルを追加し、条件ごとに条件および発光色を指定できるように対応しました。
・イメージマップ
 - イメージマップチャートを追加しました。
 - イメージマップ定義作成エディタを追加しました。
・システム設定
 - サーバプログラムの定義をおこなう「サーバプログラム管理」の設定画面を追加しました。
 - [ログ情報設定]のログレベルに「4:DEBUG」と「5:TRACE」を追加しました。
・RC Service
 - チャートの保存形式に「CSV」を追加しました。
 - 添付のZIPファイルにパスワードを設定できるように対応しました。

修正事項

・アプリケーション全体
 - Dr.Sum EA に「MBAdmin」というユーザが存在すると、ユーザ同期でエラー「データの取得に失敗しました。」が発生する点を修正しました。
 - 「Dr.Sum EA MotionBoard RC Service」サービスを起動していると、サーバの CPU使用率が100%となる点を修正しました。
 - 「Dr.Sum EA MotionBoard」サービスが異常終了した後、サービスを再起動しても MotionBoard が操作できなくなることがある点を修正しました。
 - ブラウザを「×」ボタンで終了した場合、MotionBoard のログインセッション情報が残る点を修正しました。
 - アイテム管理画面の [プラグイン] タブにて、プラグインアップロードのファイル選択ダイヤログをキャンセルした後に、画面上で右クリックすると、[ボードにアイテムを追加] などの使用できないメニューが表示されてしまう点を修正しました。
 - ユーザ設定にて [言語] を「英語」に設定している場合、ナビゲータの右クリックメニューに [Delete Item] が表示されない点を修正しました。
 - 接続先の Dr.Sum EA がVer3.0SP2 の場合、無効化されているユーザでログインしたときにエラー「ログインに失敗しました。」が表示される点について、「認証エラーが発生しました。指定されたユーザは利用できません。」を表示するように修正しました。
 - MotionBoard 上で右クリックし [設定]-[ローカル記憶領域] を「なし」に設定後、再度 MotionBoard にログインすると、エラー「予期せぬエラーが発生しました。」が発生することがある点を修正しました。
 - 小さいサイズのテキストアイテムの編集画面でコンボボックスやカラーピッカーのプルダウンが表示されないことがある点を修正しました。
 - Flash Player のバージョンが 10.1 の PCで、以下の画面の右クリックメニューが表示されなくなる点を修正し、表示名を変更しました。
  ・スタートナビ,ボードツリー
  「切り取り」→「ボード切り取り」、「削除」→「ボード削除」、「ファイル貼り付け」→「ボード貼り付け」
  ・アイテムナビゲータ
  データセットの「削除」→「データセット削除」、アイテムの「削除」→「アイテム削除」
 - MotionBoard からMotionBoard 連携モジュールを使用し Datalizer へ接続した場合、正しくメモリが解放されないことがある点を修正しました。
 - MotionBoard のサービス「Dr.Sum EA MotionBoard」が異常終了した場合に、サービスを再起動すると、ログインページを表示した際に「HTTPステータス 404」エラーとなり、ログインに失敗することがある点を修正しました。
・ボード全体(スタートナビ、ボードツリー、アイテムナビ、メニュー)
 - チャートメニューからチャートエディタを呼び出す際に、操作状態が存在する場合には、確認ダイアログを表示するようにしました。
 - ボード定義保存時に操作状態が保存されていないチャートが存在する場合、未保存のチャート定義名を確認ダイアログで一覧表示するようにしました。
 - [新しいウインドウでドリルダウン]でドリルダウンした場合、アイテムナビゲータ上に表示されるドリルダウンの新しいデータセットの名称に番号を付加するようにしました。
 - ウインドウサイズの最小値を、幅 100 → 75、高さ 100 → 25 へ縮小しました。
 - ウインドウの最大化等の各種アイコン画像を変更しました。
 - メニューの「ボード編集」「システム設定」を1つのメニューに統合しました。
 - グラフィック描画モードのツールバーにて、各アイコンのツールチップが「Message Not Found」となり、正しいメッセージが表示さない点を修正しました。
 - ナビゲータからチャートのプロパティ画面を表示し、アイテム名を変更しても保存されない点を修正しました。
 - アイテムの「ウィンドウ設定を開く」アイコンにて「常にウインドウ枠を表示」にチェックをつけた場合に、ボード定義、またはユーザ定義の保存をおこなってもボードを開きなおすと保存されていない点を修正しました。
 - メニューアイテムを作成しても、ショートカットのメニューが動作しない点を修正しました。
 - アイテム管理などの画面でキーワードを入力して検索をおこなうと、ツリー構造は絞り込まれるにも関わらず、右ペインの一覧にはアイテムが表示されない点を、検索結果にヒットするファイルが存在する最初のフォルダを開いた状態で検索結果を表示するように修正しました。
 - メニューアイテムを作成している際の、メニューバー表示の更新速度を改善しました。
 - 外部接続設定の [Datalizer] タブにて、[リンク用URL] のみ設定した場合、[設定] ボタンをクリックしても、設定内容が保存されない点を修正しました。
 - Internet Explorer 利用時、全角文字を含む名称のボード定義をダウンロードすると、ダウンロード完了メッセージ中のファイル名が文字化けする点を修正しました。
 - メニューアイテムを設定しているボードをメニューアイテムに登録した場合に、ショートカットのメニューが動作しない点を修正しました。
 - アイテムが 2 つ以上配置されているボードを表示し、ボード同士のリレーションを設定後、[ユーザ操作]-[メモ追加] にてメモを追加すると、設定したリレーションが消えてしまう点を修正しました。
 - アイテムが非表示の場合、[操作状態保存] から操作状態を保存し、[ボード編集] を選択すると、アイテムナビゲータから非表示のアイテムが削除されてしまう点を修正しました。
 - ボード定義の編集中にウインドウモードを「通常モード」から別のモードに変更し、ボード定義を保存しても、「通常モード」に戻ってしまう点を修正しました。
 - ボード上に編集中のアイテムがある場合に他のボードを選択すると、編集中の内容がクリアされて選択したボードへ遷移できてしまう点を修正しました。
 - [ユーザ操作]-[ユーザ設定]から「言語」を日本語 から英語に変更しても、メニューが日本語のままとなってしまう点を修正しました。
 - マウスオーバーモードを設定した場合、アラート条件が設定された集計表内にマウスポインタを合わせなければ、アラート表示 (点滅) されない点を修正しました。
 - メニュー[表示/操作]-[ウィンドウモード]の設定と、ナビゲータの右上にある「グラフィック描画モード切り替え」ボタンの表示切替が連動しない点を修正しました。また、メニュー[表示/操作]-[ナビゲータ]-[非表示]の設定と、ボードの右クリックメニューの「ナビゲータ表示」が連動しない点を修正しました。
 - ボードツリーやスタートナビゲータのフォルダを右クリックして [権限設定]を表示すると、内部的に使用している「MBAdminGroup」が表示されてしまう点を修正しました。
 - 「アイテム管理」から CSV をダウンロードしても空のファイルが出力される点を修正しました。
 - Flash Player デバッグバージョンを使用している場合、ボードのプロパティ画面を表示した状態でアイテムナビゲータ等から[アイテム一覧]に表示されているアイテムを削除後に[アイテム一覧]から削除したアイテムの[編集]ボタンをクリックすると、スクリプトエラーが発生する点を修正しました。
 - アイテムタイトルの「再読込」「ウインドウ設定を開く」「ウインドウを最大化」「ウインドウを閉じる」ボタンのスタイルを変更しました。
・チャート
 - 集計表のチャート上でセルを選択すると、セルを一つも選択していない状態に戻れない点を、[Ctrl]キーを押しながらセルをクリックすると選択状態を解除できるようにしました。
 - ドリルダウンを別ウィンドウで実行した際の、アイテムナビゲータのデータセット名が"DS_n-n"(nは数字)となっていた点につき、ドリルダウン元のデータセット名を引き継ぐように変更しました。
 - ボード編集時、チャートアイテムのプロパティ画面に [アイテム編集] ボタンを追加し、チャートエディタを起動できるようにしました。
 - マウスオーバーモードを設定した場合、アラート条件が設定されたチャート内にマウスポインタを合わせなければ、アラート表示 (点滅) されない点を修正しました。
 - チャートの数値軸を左右に分けて表示する際に、軸の表示が左右同じになるなど、不正な状態となることがある点を修正しました。
 - テキストアイテムの背景色が透明の場合に、テキストアイテムを右クリックすると Flash Player 標準のメニューのみが表示される点について、ボード背景の右クリックメニューを表示するように修正しました。
 - チャートメニューの [チャート定義を保存] で以下の項目が保存されない点を修正しました。
  ・ダイナミックチェンジアイコンで変更できるすべての情報
  ・チャートに表示される行項目ラベルの傾き
 - チャートエディタで以下の項目の設定が有効にならない点を修正しました。
  ・[チャートエリア設定]-[折れ線・棒系設定]-[ウォーターフォール]-[ウォーターフォールの設定] の「データラベルの初期表示」
  ・[チャートエリア設定]-[折れ線・棒系設定]-[対極棒]-[対極棒の設定]の「データラベルの初期表示」
 - チャートエディタに以下の項目を追加しました。
  ・[チャートエリア設定]-[共通設定]-[軸]-[数値軸の設定]に「ゼロを軸の中心にする」
  ・[チャートエリア設定]-[円・レーダー・ゲージ設定]-[円]-[円の設定]に「プラス側を表示する」
  ・[チャートエリア設定]-[折れ線・棒系設定]-[積み上げ共通]-[積み上げチャートの設定] に「表示するデータ方向」
 - 右クリックメニューのリンクが外部URLの場合、別ウインドウでリンク先を開くように変更しました。
 - ドリルスルー時に項目の並び順を指定できるように変更しました。
 - ドリルアップ時にドリルダウン履歴が1つしかない場合、履歴の選択をスキップするように修正しました。
 - チャートエディタのプレビューで使用できないメニューはグレーアウトするように修正しました。
 - 散布図・バブルチャートで、チャートエリア設定にある軸の設定が反映されない点を修正しました。
 - ドリルダウン後の項目入れ替え操作時、ドリルダウンした項目が表示されず、項目入れ替えの結果が正しく反映されない点を修正しました。
 - 差分積み上げ棒を表示している場合、チャートを横向きに変更するとスライダーとスクロールバーが積み上げ棒と重なって表示されてしまう点を修正しました。
 - Flash Player デバッグバージョンを使用している場合、差分積み上げ棒を表示している際に、チャート切り替えをおこなうとスクリプトエラーが発生することがある点を修正しました。
 - チャートエリアにスクロールバーが発生しない程度にウインドウサイズを小さくしている、かつ[常にウインドウ枠を表示] のチェックを外している場合、集計表のチャートで、集計表のサイズが小さいチャートエリアに余計な枠線が表示される点を修正しました。
 - チャートの種類が集計表で、かつダイナミックチェンジアイコンがすべて非表示の場合、チャートエリアの上部に不要な余白が表示される点を修正しました。
 - 行のみ、または列のみと集計項目を配置した Dr.Sum EA のデータソース定義を参照したチャートを配置すると、集計データの中に項目名の情報が含まれて表示されてしまう点を修正しました。
 - Flash Player デバッグバージョンを使用している場合、階層集計をおこなうチャート定義で、途中階層の集計中にシステム設定を開くと、スクリプトエラーが発生する点を、ボード定義が変更された場合には階層集計処理を中断するように修正しました。
 - 折れ線縦棒コンボの「列スタイルを変更する」で「列を曲線にする」を選択しても、折れ線で表示される点を、正しく曲線を表示するよう修正しました。
 - チャートエディタの [チャートエリア設定]-[列項目]-[線種表示設定] で、「対象列(行)項目名」、「対象集計項目名」に条件を入力後、線種などを変更しても、設定が反映されない点を修正しました。
 - チャートを集計表に変更後、チャートメニューの [設定]-[項目変更] 画面で行項目のチェックをすべて外し、列タブを最下層に変更すると合計の値が倍になって表示される点を修正しました。
 - データソースエディタでドリルダウン(シナリオ)を設定し、[アイテムナビゲータ]-[データセット]-[プロパティ] からシナリオを選択後、[詳細設定]ボタンから、ドリルダウン時のチャートを設定した際、ドリルダウン(シナリオ)が利用できない点を修正しました。
 - データソースの行に項目を 2 つ配置し、行項目をすべて無効に設定後、ドリルアクションボタンより、無効にした行項目をすべてドリルダウン(シナリオ)に追加し、ドリルダウンを 2 回おこなった際、ドリルダウン(シナリオ)が利用できない点を修正しました。
 - 対極棒チャートを表示し、[集計項目] タブを任意の項目に選択しても、ダイナミックチェンジアイコンの軸選択のプルダウンの内容が更新されない点を修正しました。
 - 「新しいウィンドウでドリルダウン」を設定しているチャート定義名を "既存の定義名"+"ドリルダウン名" から "既存の定義名" に変更しました。
 - 折れ線チャートにて、時系列予測を実行した後、系列をソートすると折れ線がすべて表示されないことがある点を修正しました。
 - 折れ線チャートにて、時系列予測を実行した後、予測データを削除するとエラー「予期せぬエラーが発生しました。」が発生する点を修正しました。
 - 集計表にて、行/列項目の描画範囲と集計項目の描画範囲が 1 ピクセルずれている点を修正しました。
 - バブルチャートにて四角のデータポイントを指定した際、白色の半透明で表示されていた点を、枠線と同色の半透明で表示されるように修正しました。
 - ゲージチャートを表示し、ダイナミックチェンジアイコンより「合計して表示する」を選択しても、値が変わらない点を修正しました。
 - Dr.Sum EA Server Settings の [OLAP] タブ-[最大クロス集計セル数] の列数を超えているデータソースを使用して作成したチャートを表示すると、エラー「データソース定義ファイルの解析でエラーが発生しました。定義内容が不正です。」が発生することがある点を修正しました。
 - 「他の項目」を検索条件に指定したデータソースを使用したチャートにて、検索条件に設定した内容が反映されない点を修正しました。
 - チャートエリア設定の [列項目]-[条件による色変更] にて事後計算項目の色を設定しても反映されない点を修正しました。
 - 事後計算項目に別名を指定したチャートをボードに配置した場合、チャートエリアに事後計算項目が表示されなくなる点を修正しました。
 - [アイテム管理] 画面にてチャートをコピーし、続けて別のフォルダのチャートをコピーした後、チャートを貼り付ける際にエラー「CODE[-1100] ファイルが存在しません」が発生する点を修正しました。
 - [初期表示チャート] を「集計表」に設定しているチャートをボードに配置し、「操作状態保存」を選択後再度ボードを開くと、チャートエリアが何も表示されないことがある点を修正しました。
 - チャートエリア設定の[右クリックメニュー設定]で「列スタイルを変更する」を「右クリックメニューで使用しない機能」に追加しても、縦棒チャートを右クリックで「列スタイルを変更する」が使用できてしまう点を修正しました。
 - 列項目または行項目が 3 つ以上存在するデータソースで、「この階層で集計する」にチェックを入れて、集計階層を変更すると、チャートエディタの集計階層が 2 階層目に固定され、かつ集計項目の表示が列(行)から行(列)に変更されてしまうことがある点を修正しました。
 - ボード編集時にアイテム管理からチャートを追加する際、「絞り込みフィルタも一緒に表示する」のチェックをしても、チャートを表示するとフィルタが表示されない点を修正しました。
 - 集計項目へ二つ以上の項目を配置した折れ線チャートの[チャートエリア設定]にて、[軸の固定]を[他の軸に合わせる]に設定しても、軸が統合されない点を修正しました。
 - ドリルスルー表示画面を「×」で閉じると、以降のドリルダウン、ドリルスルーの項目選択画面が無応答となる点を修正しました。
 - バブルチャートで、ダイナミックチェンジアイコンから [データラベルを表示] と [値を表示する] を選択すると、データラベルが表示されない点を修正しました。
 - 集計表にフィルターが設定されている場合、集計表のチャートメニューにある [設定]-[項目変更] で列項目をすべて非表示にし、ダイナミックチェンジアイコンで [集計項目を行に表示] と [合計を表示しない] を選択すると、ヘッダーのみの集計表が表示される点を修正しました。
 - 集計表にフィルターが設定されている場合、ダイナミックチェンジアイコンで [集計項目を列に表示] を選択し、ソートアイコンでソート順を変更した後に [ユーザ操作]-[操作状態保存] をおこなうと、ソート順が保存されない点を修正しました。
 - データソースエディタの [ソート]-[設定] で「カスタムリスト使用」にチェックを入れて保存した後に、チェックを外して保存しても、再度、[ソート]-[設定] 画面を開くとチェックが入ってしまう点を修正しました。
 - データソースエディタにて、事後計算項目を作成するための計算式のボタンの表示名を行/列項目の区別がつくよう修正しました。
 - [チャートエリア設定]-[共通設定]-[軸] の [数値軸の設定]-[表示] に「一つに集約する」を選択し、[単位] に集約軸の [軸の単位] を設定しても、設定した単位で表示されない点を修正しました。
 - 集計表のチャートで、データ入力項目に値を入力し保存をおこなうと、入力済みの他のセルの「最終更新日」も更新されてしまう点を修正しました。
 - アイテムナビゲータで、すべてのチャートを非表示にした後、[ユーザ操作]-[操作状態保存] で操作状態を保存すると、ボードを再度開いた際に、「データ取得中」のプログレスバーが表示されたままになる点を修正しました。
 - リスト表示したフィルターで値を選択しても、選択した値が反映されないことがある点を修正しました。
 - チャートの行/列/集計項目タブを Ctrl キーを押しながら複数選択した後、現在表示しているブラウザ以外のウィンドウをアクティブにすると、タブが正常に選択できない点を修正しました。
 - [共通設定]-[軸]-[数値軸の設定]-[最大値、最小値] の「最小」と「最大」の設定にて、マイナス値を入力できるようにしました。
 - [共通設定]-[列項目]-[列の設定]-[条件による色変更] の「集計値」の設定にて、マイナス値を入力できるようにしました。
 - チャートエディタの [チャートエリア設定]-[折れ線・棒系設定]-[全般] にて「ダイナミックチェンジアイコンをチャートに重ねて表示する」のチェックを外しても、ダイナミックチェンジアイコンと差分チャートが重なって表示される点を修正しました。
 - CSV ファイルのデータソースで、集計項目になにも配置しない状態のままデータソースを保存し、そのデータソースについて、チャートをボード上に配置した場合に、空のチャートが表示されていた点をエラー「データの取得でエラーが発生しました。集計項目が設定されていません。」を表示するように修正しました。
 - チャートの集計結果が、Dr.Sum EA の Server Settings の [最大クロス集計セル数] の行数または列数を超えている場合、指定行数、列数以降のセルが切り取られた集計結果のチャートが表示される点を修正しました。
 - 事後計算項目に使用している集計項目を非表示にしても、チャート上に事後計算項目が表示されるようにしました。
 - 棒チャートにて差分積み上げ棒を表示する設定の場合、チャートの行項目タブで任意のデータを選択しても、マウスオーバーで表示されるデータチップには先頭データの情報が表示される点を修正しました。また、ウォーターフォールチャートの場合、データチップのほかにチャート表示も先頭データとなる点を修正しました。
 - チャートアイテムの行・列項目タブにて項目数が多くスクロールバーが表示されると、Shift キーにて複数項目を選択しても項目を全て選択できないことがある点を修正しました。
 - アイテムプロパティからチャートのアイテム名を変更しても、チャートエディタのアイテム名に反映されない点を修正しました。
 - チャートメニューの [軸の設定] にて [軸の表示名] を設定した内容が、[チャートスタイル変更 - 軸の最大値、最小値設定] の [対象集計項目名]に反映されてしまう点を修正しました。
 - [操作状態保存] をおこなっても、チャートの列の並び順が保存されない点を修正しました。
 - データ入力用項目を配置している集計表にて、行もしくは列を追加した後、行項目と列項目を入れ替えた場合に、追加した行や列が表示されてしまう点を修正しました。※行項目と列項目を元に戻した場合は、追加した行や列が再表示されます。
 - チャートエディタの [チャートエリア設定]-[折れ線・棒系設定]-[対極棒]-[対極する軸のスケール] を「中心」や「割合表示」に設定しても、設定内容が反映されない点を修正しました。
 - チャートエディタの [チャートエリア設定]-[散布図・バブル設定]-[散布図]-[データラベルの初期表示] を「表示する」に設定しても、再度チャートエディタを表示すると「表示しない」に戻ってしまう点を修正しました。
 - 集計項目を 2 つ以上配置し、[集計項目 1 の累計(行)]-[集計項目 2 の累計(行)] となる事後計算項目が設定されているデータソースを使用して集計表を作成すると、事後計算項目の合計が「0」と表示されてしまう点を修正しました。
 - 集計表で、ダイナミックチェンジアイコンの [セル内チャートの種類を変更します] のメニューから以下の設定値を変更し、チャート定義を保存しても変更内容が保存されない点を修正しました。
  ・[集計項目] に「共通」を選択した場合
   - すべての設定値
  ・[集計項目] を指定し、[個別に設定する] をチェックした場合
   - [チャートの種類] が「ランプ」の [ランプ設定]-[しきい値(赤色)]
   - [チャートの種類] が「矢印」以外の [最大値]
   - [チャートの種類] が「矢印」の [比較方向]
 - チャートエディタの [タブ設定](行項目、列項目、集計項目)で、[タブの表示] のチェックを外しても [選択タブ表示ボタンの表示] が選択可能な状態となる点を修正しました。
 - チャートエディタの [タブ設定](予測手法、クラスター)に不要な設定項目[タブの表示]、[絞り込みボタンの表示]、[初期表示タブ] が表示されていた点を修正しました。また、[選択タブ表示ボタンの表示] の設定を追加しました。
 - チャートエディタの [凡例設定] で、[その他の線の種類] または [総合計の線の種類] を設定しても、チャートに反映されない点を修正しました。
 - チャートエディタの [チャートエリア設定]-[列項目]-[色セット指定] で[選択された色セット] 欄から[色セットマスタ] 欄へ色セットを移動すると、[色セットマスタ] 欄の表示が重複して表示される点を修正しました。
 - 円、レーダー、ゲージのチャートが合計表示モードの場合に、メニューからソート順を変更できない点を修正しました。
 - チャートメニューの [軸の設定]-[軸の固定] を「全データで最小/最大を固定する」に設定しても最大値が正しく計算されない点を修正しました。
 - ダイナミックチェンジアイコンの [セル内チャートの種類を変更] にてチャートの種類に「ランプを表示する」を選択し [集計項目] で「共通」以外を選択すると [個別に設定する] にチェックを付けなくても [ランプ設定] の「しきい値」を変更できてしまう点を修正しました。
 - 集計項目が複数存在するチャートで、チャートエディタから [チャートエリア設定]-[共通設定]-[全般]-[チャート要素の初期表示数] の設定を、凡例の数より少なくなるように指定した場合、先頭の集計項目の凡例順に選択されていた点を、集計項目によらず凡例の上から順に表示状態となるように修正しました。
 - 集計表の行/列のサイズを変更しても、変更内容が保存されない点を修正しました。
 - チャートメニューの[設定]-[集計項目のフォーマット]-[小数点以下桁数]を変更してタブの階層集計をおこなうと、変更した小数点以下桁数が初期状態に戻ってしまう点を修正しました。
 - チャートエリアに追加したテキストの内容が、チャートアイテム名に置き換わってしまう点を修正しました。
 - チャートエディタの [チャートエリア設定]-[共通設定]-[軸]-[行軸の設定]-[カラー指定] の初期値は「ID 4: 色セット名 Deep」であるにもかかわらず、色セットが何も設定されていないことがある点を修正しました。
・明細
 - アイテムプロパティから明細のアイテム名を変更し、ボードを保存すると、再度ボードを表示した際に明細の内容が何も表示されなくなる点を修正しました。
 - ドリルスルー画面で [全非表示] ボタンをクリックするか、すべての項目のチェックを外して [OK] ボタンをクリックした際、エラー「一つ以上の項目を選択してください。」を表示するように修正しました。
 - 明細表の「表示設定変更」で [全非表示] ボタンをクリックするか、すべての項目のチェックを外して [OK] ボタンをクリックした際、エラー「一つ以上の項目を選択してください。」を表示するように修正しました。
 - 明細が配置されているボードにて、明細のデータソースを削除すると、再度ボードを開いたときに、データ 0 件の明細が表示される、またはエラー「予期せぬエラーが発生しました」が発生し、ボードが表示されない点を修正しました。
 - アイテムナビゲータにて、明細アイテムをいったん非表示にすると、再度表示に設定しても、明細データが表示されない点を修正しました。
 - 複数のページでデータが表示される明細アイテムで、検索条件を実行するとエラー「データの取得でエラーが発生しました。該当データが存在しません。」が発生しデータが絞り込まれない点を修正しました。
 - 明細アイテムのメニューから移動先の行数を指定すると、次ページへ移動するアイコンが反応しなくなる点を修正しました。
 - 明細表にて表示行数入力欄に最終行数を入力して最終行を表示させた後前のページに移動すると「1ページに表示する行数」に設定された行数分のデータが正しく表示されない点を修正しました。
 - 明細の列の表示/非表示設定をおこなう画面でドラッグアンドドロップ操作で列項目の並び順を入れ替えられるようにしました。
・フィルター
 - フィルタを配置したボードを編集モードで表示し、集計項目を選択後に「保存」ボタンを押しても、ボードを開きなおすと、集計項目の選択状態が「すべて」になってしまう点を修正しました。
・コメント掲示板
 - コメント入力用ダイアログが別ウィンドウで表示されるように変更しました。
・データソース
 - データソースエディタにて、事後計算項目を作成するための計算式のボタンの表示名を行/列項目の区別がつくよう修正しました。
 - チャート、明細のデータセットを別のディレクトリに存在するデータソースに変更後、再度元のデータソースに戻して編集すると、エラー「データソースの取得に失敗しました」が表示され、プログレスバーが表示されたままになる点を修正しました。
 - データソースエディタにて、集計項目の [集計方法] にどの集計方法を設定しても、データラベルおよびデータチップの集計タイプに「合計」と表示される点を修正しました。
 - アイテムナビゲータからデータセットのプロパティ画面を開き、[データソース編集] ボタンからドリルスルー(シナリオ)を追加した場合、データセットのプロパティ画面に設定内容が表示されない点を修正しました。
 - [アイテム管理]-[データソース]タブ-[drsum] のデータソースにて集計項目名に別名が設定されており、その項目に検索条件を設定している場合、そのデータソースをチャート、または明細で選択するとエラー「データの取得でエラーが発生しました。指定された項目が存在しないか、参照権限がありません。」が発生する点を修正しました。
 - CSV ファイルのデータソースを使用した明細でメニューの [設定] アイコンより「1ページに表示する行数」を 1 に設定しても全件表示される点を修正しました。
 - 明細表の各列の横幅におさまらない長さのデータが、「・・・」と省略して表示されていた点を、折り返してデータを表示するように修正しました。
 - [他の項目] を検索条件に指定した Dr.Sum EA のデータソースを使用し、明細表を表示すると、エラー「Dr.Sum EAでエラーが発生しました。」が表示される点を修正しました。
 - データソースエディタよりアラート条件や検索条件を設定する際、値の設定画面にて表示タイプを [複数項目] に設定し、複数のデータを追加した後[キャンセル] で画面を閉じると、再度値の設定画面を表示したとき、 [使用項目(1)] の設定欄に不正なデータが残ってしまう点を修正しました。
 - データソースエディタにて事後計算項目を設定する際、集計項目一覧をスクロールすると項目名が隠れてしまう点について、項目名表示位置は固定してスクロールされるよう修正しました。
 - カスタム項目の値に「,(カンマ)」が含まれるデータソースをチャートに選択すると、エラー「データソース定義ファイルの解析エラーが発生しました。定義内容が不正です(unknown)」が発生する点を修正しました。
 - 「事後計算項目」の設定画面、またはダイナミックチェンジアイコンの [選択したセルから配下のセルに値を割り振ります。] をクリックした際に表示される画面で、 [最初(列)] ボタンをクリックすると、 [最初(行)] ボタンをクリックした際の値(CategoryFirst([項目名])が代入されてしまう点を修正しました。
・システム設定
 - [外部接続設定]、[ログ情報設定]、[MotionBoardサーバ制御] の設定画面を [システム設定] に統合しました。
 - [システム設定]-[外部接続設定] にて、Dr.Sum EA Ver3.0 SP3 に接続した場合、[Version] に「3.0 higher」と表示されていた点を修正しました。
 - [システム設定]-[MotionBoardサーバ制御] にて、「ユーザ同期」を実行した場合、Dr.Sum EA サーバー側で LDAP 連携をおこなっていると、通常のユーザー ID のみ取り込まれていた点について、DN 形式、UPN 形式でも取り込めるように対応しました。
 - 配信タスクを設定し、スケジューラー実行するとエラー「Datalizer でエラーが発生しました。 (原因:テーブルのアクセス権限がありません」が発生する点を修正しました。
 - [ユーザ操作]-[パスワード変更] にて、「現在のパスワード」に不正なパスワードを入力してもパスワード変更がおこなわれていた点について、不正なパスワードが入力された場合には、エラー「パスワード変更でエラーが発生しました。現在のパスワードが不正です。」を返すよう修正しました。
・RC Service
 - 配信タスク一覧からタスクを削除後に、タスク一覧の変更をキャンセルしても削除したタスクが復旧されない点を修正しました。
 - メール配信タスク設定で、[アラートのみ]の設定をおこなった場合に、アラート条件に一致するチャートがなくても、メール配信がおこなわれていた点を修正しました。
 - [配信タスク]の[メール設定]-[宛先ML]に、RFC に準拠していないなど送信自体がエラーとなるメールアドレスが登録された場合、メール送信時にそのメールアドレスをスキップし警告ログを出力するように修正しました。

注意事項

・チャート
 - 列、行の並び順はチャートメニューからチャート定義に保存できるようになりましたが、チャートエディタから指定することはできません。
 - アラートの表示状態、点滅状態はチャートメニューからチャート定義に保存できるようになりましたが、チャートエディタから指定することはできません。