Dr.Sum EA Datalizer 3.0から3.0SP1へのリリース情報

公開日時:2009/02/01 00:00 記事番号:000009186
製品ブランド:Dr.Sum

機能追加事項

1. Datalizer Server (for Web / for Excel 共通) 機能追加事項
・Windows Server 2008での動作が可能になりました。
・外部データベースとして、IBM DB2 9、Oracle 11g、SQL Server 2008 へ接続が可能になりました。
・Datalizer for Webのブラウザとして、FireFox 3.0 が利用可能になりました。
・Dr.Sum EA Datalizer MotionChart の利用かできるようになりました。※MotionChart は Datalier for Web のオプション製品です。
・Windows の ZIP 圧縮を考慮し、管理ディレクトリのフォルダ名を[.conf]から[_CONF]へ変更しました。また、システム移行ツールに[.conf]から[_CONF]への変換処理の選択機能を追加しました。
・システム環境設定画面のDr.Sum EA 接続情報へ、接続先のDr.Sum EAのバージョンを表示するようにしました。
・ログ出力ファイル「filejuggle.log」を追加しました。画面レイアウト設定や Motion Chart で作成されたファイル管理に関するログが記録されます。
・PDF出力時クライアントのフォント環境に影響されず、固定のフォントで出力できるよう、のフォント埋め込み機能を追加しました。
・サンプル適用ツールの[ガイドデータファイルを上書きします。]機能がユーザデータを残したまま追加・更新できるようになりました。
・サンプル定義ファィルの種類を追加しました。
forExcel編(Dr.SumEAVer3専用) / forWeb編 / forWeb編(Expert・Dr.SumEAVer3専用)
・ユーザの環境設定のデフォルト値をサーバ側で一括設定・変更できる機能を追加しました。
・メニューバー[ユーザ情報設定]-[環境設定]のメニューの表示有無を設定できる機能を追加しました。
・Datalizer Expert にてパーソナルディレクトリ(ユーザ個別タブ)に保存している定義ファイルを、他のユーザのディレクトリへ送る機能を追加しました。
・定義ファイル、及びディレクトリをバックアップし、クライアント端末に保存する機能を追加しました。
・グループ別権限設定に、[PDF 出力できるグループ] を追加しました。
・バージョン情報に Excel の詳細バージョン、利用端末のメモリ情報、インストールファイルの表示を追加しました。
・スクリプト事後計算に [後項目比] を追加しました。
・Dr.Sum EA 3.0SP1 のニックネーム情報をメニューバーのログインユーザ情報欄に表示する機能を追加しました。
・事後計算項目設定の[計算式(スクリプト)設定]に「後項目比」、「後項目差」、「後項目値」を追加しました。
・フィルタ機能に「ABC(アイテム)」のフィルタ処理を追加しました。
・システムのバージョン情報をブラウザにて確認することが可能となりました
2. Datalizer for Web機能追加事項
・抽出条件設定で、表示上と実際の検索データを異なる設定ができる機能を追加しました。
・ユーザページの画面上部のメニューにて[ヘルプ]欄の表示非表示の切り替えが可能になりました。
・クロス集計実行後、ドリルダウンプレビューされた状態で結果表を初期表示する機能を追加しました。
・項目詳細設定で、総合計や合計行に対して集計データを参照した計算式が利用できるよう以下のタイプを追加しました。
合計行(行)集計値計算/合計行(列)集計値計算/総合計(行)集計値計算/-総合計(列)集計値計算
・項目詳細設定にてパターン「列行項目データ」設定時、任意の項目データを除外する機能を追加しました。
・項目詳細設定にて集計データを、任意の文字に置き換えて表示できる機能を追加しました。
・項目詳細設定の「ターゲット指定」で、「データ」欄に「!blank」および「!null」の指定が可能となりました。また、演算子として以下の設定値を追加しました。
「より小さい()」/「以下(=)」
・集計表に利用するテーブルを集計実行時に選択できる機能を追加しました。
・Dr.Sum EA の項目毎の情報(カージナリティ数コメント)を[フィールド詳細設定]画面でも参照可能となりました。
・集計結果表で実行した集計項目ソートの位置を再度の集計実行でも前回行ったソート位置を記憶し表示する機能を追加しました。
・Excelファイルへの出力時、 XLSX ファイル出力が可能になりました。
・集計項目数が 1 つの場合など集計タイトルが不要な場合、集計タイトルを表示しない機能を追加しました。
・行項目または列項目を設定していない集計表の場合に、合計総合計欄を集計項目の横に出力する機能を追加しました。
・行項目または列項目を設定していない集計表の場合に、列行項目の横に合計欄を、集計表の上に総合計欄を出力する機能を追加しました。
・レイアウトパターン設定にて、行項目または列項目の項目の順番を入れ替えたパターンの登録が可能となりました。
・同じフォーマット書式を複数の項目に適用できる機能を追加しました。マルチ集計結果の出力アイコンの表示非表示制御をマルチ集計定義ファイル単位で設定可能となりました。
・明細一覧明細一覧(外部)の HTML 表示 でスクロール表示ができる機能を追加しました。
・抽出条件設定の「フィールドタイトル」にて「複数選択」を指定した際、抽出項目の折り返し数が指定可能となりました。また、「初期値設定」「省略値含む」の設定が可能となりました。
・ユーザページでのセッションタイムアウト時のリダイレクト処理としてリダイレクト先アドレスの指定が可能となりました。
・アクセスコードによるログイン、外部認証によるログイン、またはURLを指定してのログイン時にエラーが発生した場合のリダイレクト処理としてリダイレクト先アドレスの指定が可能となりました。
・アクセスコードによるログイン、外部認証によるログイン、またはURLを指定してのログイン時にエラーが発生した場合、ログインができなかったエラーメッセージを表示する機能を追加しました。
・Excelファイル出力でも集計表の合計欄の出力が指定可能となりました。
・CSVファイル出力のセパレータ設定を定義ファイル毎に設定することが可能となりました。
・セパレータの種類に「カンマ区切り-引用符(なし)-NULL空文字」「TAB区切り-引用符(なし)-NULL空文字」を追加しました。
・明細一覧明細一覧表(外部)ドリルスルー出力において、文字列の長い項目を一定の文字数単位で折り返す機能を追加しました。
・フォーマット書式に Dr.Sum EA 3.0 の NULL データを変換する書式を追加しました。
・フォーマット書式の設定時に「フォーマット」欄をダブルクリックして表示される「編集ウィンドウ」上で、書式を入力変更することが可能となりました。書式が長い場合など「編集ウィンドウ」を使用すると、式全体を確認しながら編集することができます。
・明細一覧明細一覧(外部)にて、明細表の項目データにリンク先を設定する機能を追加しました。
・チャート設定画面にて、チャートの追加時にチャート名を指定して登録することが可能となりました。
・マルチ集計にて複数の集計表をひとつの Excel シートに出力できるテンプレートを追加しました。
・抽出条件設定時のデータパターンのデータ値を「データパターン設定」画面を開かず、リストエリアに値を直接設定することが可能となりました。
・明細出力の PDF 出力にて明細レコードを「全件」出力できるモードを追加しました。
・明細出力の PDF 出力にて「全件」出力を指定した際、明細データの出力最大行数が指定可能となりました。
・Dr.Sum EA 3.0 にて項目毎に権限設定されている情報を、定義メンテナンス画面で参照可能となりました。
・明細出力時、最大行数オーバーした際の処理を「出力最大行数まで出力する」か「出力を中止する」か設定可能となりました。
・PDF出力の全件出力時、指定した行数よりオーバーした場合警告メッセージを表示して実行の有無を確認することが可能となりました。
・明細一覧明細一覧(外部)にて Excel ファイル出力、 CSV ファイル出力に対してデータ取得件数を制御する機能を追加しました。
・結合表にて結合元の定義ファイルの集計項目が非表示項目の場合でも、結合表の[集計項目設定]画面にて表示非表示の切替が可能となりました。
・クロスマップ表の作成編集実行する機能を追加しました。
・集計画面のレイアウトを管理者ユーザが自由に配置、メンテナンスできる機能を追加しました。
・Motion Chart の設定編集実行機能を追加しました。
・メニューに表示される定義ファイルの並び順を「定義名」「更新時刻」「ファイル種類」「ソートなし」の 4 種類から選択できるようにしました。
※「ソートなし」の場合は、定義ファイルの作成順になります。
3. Datalizer for Excel機能追加事項
・クライアントコンピュータの管理者の場合、コンピュータ単位でのインストールが選択できるようになりました。
・Windows Vista に Microsoft Excel 2003 がインストールされている環境へのインストールが可能となりました。
・[システム設定]-[全般] タブに、「Webモードの処理で、"Webモードで開く"をデフォルトアクションにする」を追加しました。※この設定は、Microsoft Excel 2007 のリボン表示時にのみ有効です。
・[システム設定]-[表示]-[定義ファイル選択画面にて前回選択したディレクトリを記憶しない]のデフォルト設定を「記憶する(チェックボックス オフ)」に変更しました。
・検索条件式の演算子リテラルの表記を、forWeb の表記と統一しました。
・検索条件式設定画面に[集計実行時に集計条件ウィンドウを開く]を追加しました。
・検索条件式の設定画面より、条件式エリアに配置した項目をドラッグすることで、条件式の削除がおこなえるようになりました。
・for Web 用の定義ファイルを、for Web の形式で集計する [Web モード実行] が可能となりました。
・for Web 用の定義ファイルを、for Web のフォーマット形式を利用して集計する [Web モードで開く] が可能となりました。
・for Web 用の定義ファイルの[参照作成] が可能となりました。
・[Web モード実行] および [Web モードで開く] を使用した場合、for Web 形式に準じた[Excel 出力] と [PDF 出力] が可能となりました。
・for Excel 用の定義ファイルで [PDF 出力]が可能となりました。
・for Web のフォーマット書式を使用して、forWeb 形式で出力できる [フォーマット(PDF)] に対応しました。フォーマットを設定することにより、Excel 出力 および PDF 出力に結果が反映されます。
・テーブル名と更新日時をグレーアウトしました。また、テーブル名のツールチップを表示する位置を変更しました。
・グループが設定されていないユーザも、ログインが可能なように変更しました。
・ユーザID と パスワードを保存するかどうかを別々に設定ができるようになりました。
・グループ別権限設定に、[項目一覧のカスタマイズ]を追加しました。
・グループ別権限設定に、検索条件設定に関する設定を追加しました。
・グループ別権限設定に、[Web モード実行]/[Web モードで開く] に関する設定を追加しました。
・マルチ集計ファイル設計画面で、定義ファイルのセル開始位置の操作を、表示範囲で[表示範囲 BOX] で表示するように変更しました。
・定義ファイルのプロパティ [B.セル表示開始基点] で、[表示範囲BOX] を表示するように変更しました。
・明細出力時と、ドリルスルー実行時に [ソート] がおこなえるようになりました。
・スクリプト事後計算に [後項目比] を追加しました。
・フィルタのモード [基本統計量] に [集計処理時の補助情報出力]を追加しました。
・フィルタのモード [デシル(アイテム)] から [集計処理時の補助情報出力] を削除しました。
・カスタム項目設定画面で、関数のガイドの表示が可能となりました。
・Dr.Sum EA 3.0 で追加された[ニックネーム] を表示可能となりました。
・ルートディレクトリに保存できないモードを追加しました。
・シート操作の挿入/追加のリテラル変更 [挿入]から[前に追加] [追加]から[後に追加]しました。
・事前に、Datalizer Addinを 読み込みする(ON)/しない(OFF) を外部実行ファイル(DatalizerExcelLoadBehavior.exe)で設定できるようにしました。
・ドリルダウンウィンドウの画面のレイアウトを変更しました。
・集計ソート時に、クリックしたセルを基準にソート設定をおこなうよう変更しました。
・総合計に含まれる集計項目のソート対象を、集計値から総合計値に変更しました。
・集計項目セルID2番目以降に項目一覧から項目を追加できるように対応しました。
・Datalizer Express Server へ接続時、「項目一覧のカスタマイズ」が右クリックメニューから選択できるようになりました。
・forExcel 共通システム設定に [ニックネームを優先表示]の設定項目を追加しました。
・forExcel 共通システム設定に [PDF出力権限制御] [WEBモード権限制御]の設定項目を追加しました。
・forExcel 共通システム設定 に [PDFシステム値設定] の設定項目を追加しました。
・上位の前置文字列設定した項目を非表示にした際、最下位の項目に上位の前置文字列を表示するよう変更しました。
・forWebにある定義ファィルメンテナンス-[出力詳細設定]-[PDFファイル設定]の内容と[属性]-[背景色パターン]をforExcelでも設定できるよう、[PDF設定]-[PDF詳細設定]を追加しました。
・[定義ファイル]-[プロパティ(定義)]-[B.セル表示開始基点]で[表示範囲BOX]を表示するよう対応しました。

修正事項

4.Datalizer Server 修正事項
・[システム移行ツール]で Ver2.5 の定義ファイルを Ver3.0用へ移行した際、ドリルダウンの設定が移行されないことがある点を修正しました。
・定義ファイル保管場所を変更すると、定義ファイルの保存ができなくなる点を修正しました。
・[パッチ適用ツール]のファイル指定画面にて、[ファイルタイプ]が「(*.zip)」でもフォルダの選択ができるよう対応しました。
・メンテナンスメニューにて[パーソナライズ設定] -[項目一覧]より登録グループの項目を右クリック後「表示」にて表示されるディレクトリのメニューの[共通]を選択し、ディレクトリに対して「権限設定」を選択すると「指定されたページは見つかりません」のメッセージが表示される点を修正しました。
・[サーバ設定管理]-[パーソナライズ設定]において他のユーザの[有効]フラグの表示が不正になる点を、正しく表示されるように対応しました。
・Datalizer for Excel または Datalizer for Web の Server をインストールすると、システム情報の「ファイル出力」でシステム情報のない 0 バイトのファイルが作成されてしまう点を修正しました。
・「システム移行ツール」で、Datalizer Ver.2.5SP2 の定義ファイルを移行した後、移行されたディレクトリに対して、権限設定/名前の変更/削除/ディレクトリ移動操作を行うと、別のディレクトリに対して処理内容が設定されてしまう点を修正しました。また、システム移行ツールに、ディレクトリの整合性チェック機能を追加しました。
・Datalizer Server に含まれていた[SQLガイド]の「フォーマット : SUBSTR([?],1,?)」に以下の誤りがあったため修正しました。
・システム移行ツールで旧バージョンから移行した定義ファイルに外部マスタ参照が設定されている場合、定義ファイルメンテナンス画面で再度保存しようとすると、保存画面で「外部DB連携先項目が存在していません。レイアウト設定の画面にて、設定を見直して下さい。」のエラーが表示され、定義ファイルを更新、複製できない点を修正しました。
・前項目比(直上)の事後計算項目の前に非表示の集計項目が存在する場合に、前項目比(直上)の結果が 0 となってしまう点を修正しました。
・[システム移行ツール]で[EAサーバ設定外部連携DB]を有効にしDatalizer Ver2.5 の[外部連携DB設定ファイル]で[コネクションプール]を「する」と設定した場合、移行されない点を修正しました。
・定義ファイルが格納されている「共通」メニューにおいて、ディレクトリの参照権限の有無により、メニューの表示内容を制限するよう修正しました。また、「ユーザ個別」メニューについては、ディレクトリメンテナンス権限の有無に関係なくディレクトリの操作が可能となるよう修正しました。
データパターンやデータパターン(リンク)の設定で、データ取り込み先にDr.Sum EA Ver3.0 または Ver3.0SP1 の外部連携DB を指定すると、データ参照時に「該当なし」と表示されてデータの取り込みに失敗する点を修正しました。
・[共通データパターン設定]-[参照] 画面からデータリンクのデータを参照した場合に、ソート用のキー項目が SQL に指定されず、データが重複して表示されることがある点を修正しました。
・ディレクトリの権限設定「利用可能グループ」にグループ設定を行った場合、Administrator 権限グループでログインしても定義ファイルの名前の変更が行えなかった点を修正しました。
・システム移行ツールで旧バージョンの定義ファイルを移行した場合、定義ファイルの「ファイル名」が「定義名」、「タイトル」が「説明」に移行されるため、移行後のメニューが Ver2.x と同一にならず「タイトル」が表示されない点について、設定ファイルで「タイトル」(Ver3.0 の「説明」)をメニュー表示できるように対応しました。
・サンプル適用ツールの内部仕様を変更し、定義のリンク設定が維持されるようになりました。
・Datalizer定義リンクを用いてVisualizerのページにDatalizerの検索条件を配置した場合、その抽出条件のガイドが検索条件の表示枠内にしか表示されない点について、ガイドを別ウィンドウで表示するように修正しました。
・最下位の行項目を非表示に設定した定義ファイルにて、[集計条件調整項目]ですべての集計項目を非表示に設定して集計を実行すると、集計表が崩れて表示される点を修正しました。また、このとき最下位に表示される行項目のグループサプレスを自動的に解除するように修正しました。
・[サンプル適用ツール]でコピーしたサンプル定義ファイルにリンク先が指定されているとリンク先の再設定が必要な点を修正しました。
・ダイレクトログイン時にログイン不可の状態の場合、ログイン画面が表示されていたのをエラー内容が表示されるように修正しました。
・集計ソート処理でのソートキー指定で、項目データの NULL を基準にソートできるよう修正しました。
・システム移行ツールで旧バージョンの定義ファイルを移行した場合、定義ファイルの「ファイル名」が「定義名」、「タイトル」が「説明」に移行されるため、移行後のメニューが Ver2.x と同一にならず「タイトル」が表示されない点について、設定ファイルで「タイトル」(Ver3.0 の「説明」)をメニュー表示できるように対応しました。
5.Datalizer for Web 修正事項
・集計結果表からドリルダウン後にドリルスルーリンクを実行した場合にリンク先の抽出条件にドリルダウン時に選択した項目のデータが渡されない点を修正しました。
・[ドリルダウンアクション選択画面]にてカンマ(,)を含む文字データを選択すると、正しく文字列が渡されない点を修正しました。
・フォーマットの補助書式にてマイナス符号を設定し、集計結果を CSV 出力するとマイナス符号が二重に表示される点を修正しました。
・Internet Explorer 6 で集計を実行した際に、ブラウザのURLの制限を超えた場合、「リクエストの情報量が多いため、集計できませんでした」というメッセージが表示された後、「ただいま集計中...」のダイアログ表示が消えない点を修正しました。
・チャート設定にて、[固定項目] に事後計算項目を使用した場合に、集計表の値とは異なる値がチャートに表示される点について、集計表の値と再計算値のいずれかを選択可能としました。
・複数のフィルタ処理を同時に利用した場合、事後計算項目の総合計値が表示されないことがある点を修正しました。
・抽出条件の画面出力タイプに入力項目(年月)」を選択した場合、集計を実行した後に、抽出条件欄が初期値に戻ってしまう点を修正しました。
・合算フィルタを使用した集計結果表において、[集計データが空白行または列の表示] を「表示しない」に設定しても空白行(または空白列)が表示されてしまう点を修正しました。
・Dr.Sum EA 3.0 のデータベースにて「NULLと空文字列の区別」の設定を「区別する」に指定し、テーブルに のデータが存在している場合に のデータからのドリルダウン実行が行えない点を修正しました。
・抽出条件設定にて、集計結果データ抽出条件をセットした場合の集計結果表での抽出条件情報の表示欄に、対象の項目名が表示されていない点を修正しました。
・明細一覧(外部)にて、Dr.Sum EA 以外の DB を使用した場合の「明細項目」で項目を追加すると、設定済みの項目の集計方法がクリアされる点を修正しました。
・集計値層別の副フイルタ処理に[事後計算項目]及び[DL事後計算項目]の集計項目の設定があり且つ使用しているEA項目が表示状態となっている場合に、集計実行すると処理エラーとなる点を修正しました。
・Datalizer 事後計算項目を使用した Datalizer 事後計算項目を作成し、集計項目に配置した場合、前者の Datalizer 事後計算項目より後者のDatalizer 事後計算項目を前に配置すると、正しく計算結果が表示されない件を対応しました。
・データパターンに設定しているデータが半角スペースのみで構成されている場合でも、「入力項目」以外の画面出力タイプで抽出が行えるようになりました。
・レイアウト設計で事後計算項目の下に集計項目を配置し、ドリルダウンプレビューを行うと、下に配置した項目のセルに事後計算結果が表示されてしまう点を修正しました。
・Internet Explorer 7 および Mozilla Firefox を使用して集計を実行時にブラウザの URL長の制限を超えた場合、ページ表示エラーとなっていた点をエラーメッセージが表示されるように修正しました。
・チャート設定で[チャートデータに合計欄の値を優先する]を「する」に設定した場合、集計実行時に例外エラーが発生する点を修正しました。
[ユーザ情報設定]-[クライアント環境設定]の情報が、ブラウザ単位で保持されない点を修正しました。
・[属性]-[集計結果表に関する設定]の「左揃え」と「右揃え」が有効にならず、全て中央揃えになる点を修正しました。
・フィルタ機能にて合算処理をおこなった場合に、フォーマット未指定の事後計算項目が、値によって指数表記に変わってしまう点を修正しました。
・抽出条件のフィールドガイド画面にて、取込時にページが複数ある場合に、次ページで「文字列検索」に値を設定し取込時に1ページ目から再表示するように修正しました。
・外部連携DBに対して抽出条件を有効にした状態で、抽出条件の画面タイプ、入力項目の条件値の値を省略(空白)して集計実行した場合、外部連携DBのデータ取得ができず、集計結果表に値が表示されない現象を修正しました。
・フィールド詳細設定画面(一覧)にて、重複したフィールドタイトルを指定すると、[適用]アイコンクリック時に重複チェックエラーとなりますが、そのまま[×]アイコンで閉じた場合、重複したフィールドタイトルが保存されてしまう問題を修正しました。
・[ドリルスルー設定]の[タイトル]の先頭に半角数字を使用した際に、処理中にエラーが発生する点を修正しました。
・ログイン画面の URL の error パラメータでスクリプト等を実行できないようにしました。
・レイアウトパターンが「カスタムレイアウト(2)」または「カスタムレイアウト(3)」の場合に、集計結果ページに [集計実行] ボタンが表示され、そのボタンから再集計すると全件検索となってしまう点について、集計結果ページの [集計実行] ボタンを表示しないように修正しました。
・使用ブラウザが Firefox の場合、定義ファイルメンテナンスのフィルタ設定時に、[ターゲット指定] のガイド画面にて [適用] ボタンをクリックすると「ただいまサーバが混雑しているか、または許可されていないページを参照しようとしています。」のメッセージが表示される点を修正しました。
・ドリルスルーや明細出力した集計表を Excel 出力する際に、セル数の上限である65536行を超えた場合、エラーメッセージが表示されずそのまま0 KB のxlsファイルが出力されて点を、、65536行を超えた場合には、エラーメッセージが表示されるように修正しました。
・ドリルスルー及び明細一覧にて数値型の項目に対して[画面出力タイプ]が「入力項目(複数)」や「入力項目(テキスト)」など複数条件値を入力するタイプの場合に、条件データ値が抽出条件として反映しなかった点を修正しました。
・ドリルダウン項目として 1 つ以上ドリルダウンした状態でかつドリルダウンした要素からドリルダウンプレビューを実施した場合に正しくドリルダウンプレビューおこなわれない点を修正しました。
・集計実行中に表示されるキャンセルボタンを連打した際、javaScriptエラーが発生する点について、Internet Explorer 7 についてのみ極力このエラー発生を回避するように修正しました。
・明細一覧の出力時にレコード件数が「最大ソートタプル数」の設定値を超えた場合の処理について、[最大ソートタプル数オーバー時の動作]の選択を可能としました。クロス集計にて集計項目に外部連携項目を設定し、抽出条件の設定にて「外部連携で使用:オフ」とした場合、抽出条件を入力した場合と入力しない場合とで、ソート順が変わる現象について、以下のように対応しました。
-Dr.Sum EA Ver3系接続時:-定義ファイルメンテナンス[属性]にて指定されるエンコードにてソートする。
-Dr.Sum EA Ver2系接続時:-エンコード MS932 にてソートする。
・ドリルスルーリンクに「PAGEリンク」ファイルを設定し、ドリルスルーリンク元の抽出条件をドリルスルーリンク先の定義ファイルに反映、ドリルスルーリンク先の定義ファイルには「外部連携項目」が設定されている場合に、ドリルスルー実行後抽出条件情報に「抽出項目名(外部連携項目)=値」という不明な情報が表示されてしまう点を修正しました。
・クロス集計を多重度で実行した場合に、エラー「code = C5220」となることがある点を修正しました。
・クロス集計の 65536行 または 255列 を超える集計結果を Excel 出力した場合の動作を、出力可能は範囲で出力し、警告の文字を Excel ブック内に出力するよう、動作を統一しました。
・ドリルスルーリンク先定義ファィルの[条件式一覧]画面で検索パターンが設定されている場合に、リンク元定義ファイルから抽出条件で絞込みを行い、ドリルスルーを実行時の抽出条件の条件表示欄に選択項目の条件式が表示されるように修正しました。
・結合表の元定義ファイルで集計項目を非表示に設定している場合に、副ファイル側の総合計が表示されない、あるいは副ファイルの表示項目がずれてしまう点について、元定義の集計項目に非表示項目が存在していても結合表で正しく合計の再計算表示がされるように対応しました。また、クロス集計表で集計項目を非表示に設定している場合に、[集計結果データ抽出条件] の合計の再計算が正しく処理されない点についても対応しました。
・Datalizer Ver 2.5 SP2 にて、他システムから get メソッドを使用して自動ログインし集計表表示をリンク起動で行う場合に、 Datalizer Ver 3.0へバージョンアップした際に、既存集計表の定義ファイルの移行を実行し、 URL リンクを変更なく実行が可能になる機能を追加しました。
列項目を配置していない場合、集計項目設定画面にある [集計ソート処理] の設定が保存されない点を修正しました。
・[Datalizer事後計算項目] を集計項目に配置した後に、事後計算項目の設定を [EA事後計算] に変更すると、集計実行時に「C=1156(定義ファイルに誤りがあります)」のエラーが表示される点を修正しました。
・データリンクのデータ参照時や、定義ファイルメンテナンス内のデータ参照時に該当データがない場合、データベースのクローズ処理がおこなわれていなかった点を修正しました。
・事後計算項目の計算対象項目を非表示に設定している場合、事後計算項目を配置した後に、その事後計算項目のタイトルを変更すると、変更内容が集計表に反映されない点を修正しました。
・集計結果データ抽出条件によって絞り込まれた集計結果表で、集計項目よりも上位に事後計算項目を配置した場合に、集計項目の合計が表示されず、事後計算項目の合計が表示されてしまう点を修正しました。※集計結果データ抽出条件によって集計表を絞り込んだ場合、事後計算項目は合計再計算の対象外です。
・Datalizer Server の修正パッチ(DTL_30_0028.zip、バージョン3.00.0028)を適用すると、[キャッシュ利用] を「する」に設定したPAGEリンクが動作せず、実行結果が表示されない状態になる点を修正しました。※[キャッシュ利用] は Datalizer Expert のみの機能です。
マルチ集計、結合表にて集計実行時、以下のタイプの抽出条件が反映されずに集計される点を修正しました。
入力項目(データパターン)/選択項目(データパターン)/リスト項目(データパターン)/ラジオ項目(データパターン)
・カスタム項目の作成後、抽出条件[複数選択]の[項目設定]-[取得項目設定]を設定し、再度[取得項目設定]をクリックすると、「ロード中」のメッセージ表示後、白い画面のままとなり編集ができなくなる点を修正しました。
・結合表で主ファイルと副ファイルの両方に「集計結果データ抽出条件」を設定した場合、抽出条件を指定して実行すると、エラー C5220 発生する点を修正しました。
・項目詳細設定でタイプ「合計行(行)集計値」を設定すると、事後計算項目より後ろに配置している集計項目の合計値が不正になる点を修正しました。
・Datalizer事後計算項目や事後計算項目が集計項目の先頭に配置されていて、かつ、その後ろに、非表示の集計項目が配置されている場合、非表示の集計項目以降の合計値が表示されない点を修正しました。
・レイアウトパターンがカスタムレイアウト(2)または(3)の場合に、集計条件調整項目を操作してから集計を実行し、「戻る」ボタンで元の画面に戻ると、集計条件調整項目が操作前の状態に戻ってしまうことがある点を修正しました。
・マルチ集計で、画面出力タイプが 「年付選択項目(データパターン)」の抽出条件に関連項目を設定しても、その関連項目に抽出条件が反映されない点を修正しました。※マルチ集計の抽出条件に関連項目を設定する場合は、関連元と関連先で、抽出条件の設定内容とデータパターンが一致している必要があります。
・クロス集計表にて、[集計条件調整項目] の行および列項目を未選択状態で集計実行した場合のエラーメッセージが「集計処理中にエラーが発生しました。」と表示される点について、「表示する行、列、集計項目の設定に誤りがあるため、集計処理が実行できません。 (code = C1140)」と表示されるように修正しました。
・結合表にて、結合元の定義ファイルにフィルタ設定がされている場合、結合表の [集計項目設定] で [項目操作] が許可されていても、ソートアイコンが表示されずソートがおこなえない点を修正しました。
・フィルタ設定の「トップ順位(ALL)」と「ワースト順位(ALL)」にて行列項目の最下層が [対象フィールド] の設定項目とは異なる項目のときにもフィルタ処理がされてしまう点を修正しました。
・フィルタ処理と集計タイトルを同一方向(行/列)に設定した場合、[項目操作]を[通常集計項目ソート]に設定しても集計時にソートアイコンが表示されない点を修正しました。
・マルチ集計ファイルにて、定義ファイルの順序を変更すると、一部の抽出条件の前に「削除予定」と表示されて抽出条件が無効になる場合がある点について、「設定が変更されたため、抽出条件設定項目は破棄されます。よろしいですか?」という警告メッセージを表示し、[OK]を選択時は、抽出条件の設定内容を再読み込みするように修正しました。
・フィルタ(日付ステップ)のステップ数に「Y」「M」「D」の記号を入力しても集計実行時に無効となってしまう点を修正しました。
・データパターンデータグループのコピー操作にて、コピー先の定義ファイルにデータパターンやデータグループが存在していないとエラーが発生し、コピーができない場合がある点を修正しました。
・明細一覧(外部)の定義ファイルにて、項目に[集計方法]を設定すると明細出力時に項目名と集計データの位置がずれて出力されてしまう点を修正しました。
・行と列の両方を設定したフィルタパターンに対して、行フィルタに「集計時の選択行為」-「選択できない」を設定した場合、列フィルタのパラメータを設定して集計を実行すると、設定した内容が列フィルタではなく行フィルタの選択欄に表示されてしまう点を修正しました。
・集計タイトルを行に設定した定義ファイルで結合表を作成し、項目ソートを設定すると、集計時に任意のソートアイコンをクリックしても列の総合計でソートされてしまう点を修正しました。
・[全体レイアウト設計]を「行合計(上)」に設定している場合、外部連携設定で[集計結果にないデータも含めて出力する]を設定していても対象データが表示されない点を修正しました。
・グループサプレスされた集計表をPDF出力すると、グループサプレスが解除されたPDFファイルが出力されることがある点を修正しました。
・定義ファィルメンテナンスの[レイアウト設定]にて行、または列へ同一項目を配置した場合、どちらか片方の項目を[非表示項目]に設定できない点を修正しました。
6. Datalizer for Excel 修正事項修正事項
・マルチ定義に使用されている定義ファイルの参照先テーブルなどが変更され、検索条件も変更された場合、[マルチ集計ファイル抽出条件設定]画面の項目名に変更が反映されない点を修正しました。
・[共通システム設定] によっては、Excel 2003 にて [保存] に関するメニューが非表示となる場合が有る点を修正しました。
dsi ファイルのインポート後に、レイアウト画面にタブが2つ作成される点を修正しました。
・[定義を保存する]画面のディレクトリ一覧のクリック位置と背景色の切り替わりを変更しました。
・[定義を保存する]画面のフォルダの切り替え時に、ファイル一覧をクリアするように修正しました。
・[シートのクリア方法]を[前回の集計サイズ]に設定して集計を実行後に、前回の集計結果より小さい集計結果表の実行をおこなうと、前回の集計結果表の一部が残る点を修正しました。
・Excel 2007 で、[取得行数]、[取得列数]を設定後に「定義情報をデフォルト値に戻す」ボタンをクリックすると、[取得行数][取得列数]の設定が0となってしまう点を修正しました。
・Datalizer ブックを起動した際のエクセルメニューのマスクが正しく適用されるよう修正しました。
・[システム設定]-[表示]-[集計実行後] でレイアウト設計のみチェックし、複数定義ファイルを開いた状態で集計を実行すると、レイアウト設計と項目一覧とプロパティ画面が開く点を修正しました。
・ログイン時のバージョンチェックで、Excel 2003 用のインストーラをダウンロードできるように修正しました。
・[レイアウト設計]画面にて、タブの内容が重複しないように修正しました。
・ブック保存の定義情報を自動修復すると、「項目一覧」に項目名が全て表示されないことがある点を修正しました。
・マルチ集計ファイル設計画面で、追加済みの定義ファイルを選択して[Delete]キーをクリックすると、定義ファイルが表示上削除されたように見える点を[delete]キーをクリックしても表示上削除されないように修正しました。
・定義ファイルの修復を行うと、以下の設定内容が変更されてしまう点を修正しました。
-[シートクリア方法]の設定が[前回の集計サイズ]に設定していたが[集計サイズ]に変更される
-[カスタム項目設定]で、DECODE 関数を指定していたが、"DECODE"の部分が削除される
定義ファイルの修復を行うと、検索条件式画面の「定義を開いて実行時に集計条件ウィンドウを開く」のチェックが外れる場合がある点を修正しました。
・1シート上に複数の集計表を表示する設定のマルチ集計を行った際に、行項目に設定した書式が有効とならない場合が有る点を修正しました。
・[プロパティ]-[G.シートクリア方法]で、[シート全クリア]以外を選択した場合に、セル表示開始基点を任意のセルに変更すると、1つ上の行の全てのセルがクリアされる点を、定義名、検索条件式を表示するセル(セル表示開始基点の上のセルから、右に3つのセル)のみをクリアするように修正しました。
・既存の定義ファイルの集計対象テーブルに複数のカラムを追加した場合に、対象の定義ファイルを開くと、「定義ファイルが正常に読み込みできませんでした。違う定義ファイルまたはテーブルの読み込みを行ってから、実行してください。」のエラーが表示される点について、定義ファイルの修復画面が表示されるように修正しました。
・Excel 2003 を使用時、検索条件式の「検索条件式入力」画面で「タイプ」を変更すると、一部英語表記になる点を修正しました。
・[定義ファイルメンテナンスができないグループ] に所属しているユーザでも、項目データを右クリックまたはダブルクリックした際、以下の機能は使用できるよう修正しました。
ドリルダウン(新規含む)/ドリルアップ/ドリルスルー/絞込み(新規含む)/絞込み削除/集計ソート
・定義を開く画面で右クリックメニューから「開く」を選択後、警告画面でキャンセルすると「開く」ボタンが押下できなくなる点を修正しました。
・検索条件のタイプを「データパターン」に設定し、実行時に集計条件ウィンドウを開いた場合に右クリックメニューが表示されてしまう点を修正しました。
・検索条件に半角エスケープ文字()を指定すると、検索条件表示が消える点を修正しました。
・定義ファイルのプロパティ-[セル表示開始基点]を「$B2」に設定すると、ドリルスルー結果が不正となる点を修正しました。
・Datalizer Express に接続時、プロパティをプルダウンで選択した集計項目の設定が変更されるよう修正しました。
・A1に数値を入力して集計実行すると、集計表の行項目の値にA1で入力した値が加算されてしまう問題について修正しました。
・項目一覧画面のツールチップにコメントが表示されないよう変更しました。
・ブック起動時、リボン(ツールバー)のマルチ定義設計が有効にならないことがある点を修正しました。
・Excel2007のクイックアクセスツールバーにDatalizerのメニューを追加すると、ブック起動時にエラーが表示される点を修正しました。
・定義ファイルを修復した際、項目の表示名がクリアされてしまう点を修正しました。